[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] RE: [Xen-users] HVM WinXP dom crash

  • To: Keir Fraser <Keir.Fraser@xxxxxxxxxxxx>, "Petersson, Mats" <Mats.Petersson@xxxxxxx>
  • From: jdsw <jdsw2002@xxxxxxxxx>
  • Date: Wed, 18 Oct 2006 10:23:03 -0700 (PDT)
  • Cc: xendevel <xen-devel@xxxxxxxxxxxxxxxxxxx>
  • Delivery-date: Wed, 18 Oct 2006 10:24:06 -0700
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=Message-ID:Received:Date:From:Subject:To:Cc:In-Reply-To:MIME-Version:Content-Type:Content-Transfer-Encoding; b=eBKjZ8Aga7M+ko0w+NSPe1/QBYDxYH8FWuFbJzDfRs0IXAr11rwSfp1QYjlL1ynJrqZyon1wBxFmq9ZwyURhd+ENsZbDjpMq2vHNX6SujjvFOKhZrgQJL4mb4zk/Zq3Qtc8keeGqtpfQnkRzg0jw8z39B5OLRiXZT92FSn6iSVw= ;
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>

Thanks Keir.
My hvmloader was old, got the dev86 package from http://www.cix.co.uk/~mayday and rebuilt the things. Now I am passed that error.
btw, I had seen some traffic mentioning that there is no special need to build HVM stuff on one of the mailing list, which apparently is not true.
My CDROM for windows is not bootable. Need to find the right CDROM and try it out.
(Is there a way to kick of a windows program like setup.exe...?)
Still running in to most of other problems mentioned. I might repeat the whole procedure soon and report result to the forum.

Keir Fraser <Keir.Fraser@xxxxxxxxxxxx> wrote:
If you?re still getting the bad hypercall message when the hvmloader runs, and thus unable to run ROMBIOS, then your hvmloader binary is still out of date. Where did you get 3.0.3-testing from? If you built yourself you need to download an extra 16-bit compiler (bcc). The instructions for this are listed when you try to build the HVM firmware (which fails to build if that compiler is absent). Look at /usr/lib/xen/boot/hvmloader ? what?s the timestamp on it?

 -- Keir

On 16/10/06 6:47 pm, "jdsw" <jdsw2002@xxxxxxxxx> wrote:

Resending.... can anyone help?


jdsw <jdsw2002@xxxxxxxxx> wrote:
  I tried using xen-3.0.3-testing.hg  followed most of the stuff from
Still getting the same problem when I try to start WinXP domU.  Same dmesg message about ROMBIOS. I would appreciate any help getting this and related issues resolved.

Q1  : Is the procedure ok (bit later in email) ? Do I need to do anything else ? (One interesting thing is that the kernel version that I had installed using yum, were 2.6.17-1.2187, while 3.0.3 testing.hg is got !!! )

Additionaly I am seeing the following. These are put here as they might be actual bugs or may help resolve the issue.

A .
 during startup, Between xend starting and login prompt takes 2 min.!!   I dont know whats going on ?
 some messages in  dmesg
evbug.c: Event. Dev: isa0060/serio0/input0, Type: 4, Code: 4, Value: 50
evbug.c: Event. Dev: isa0060/serio0/input0, Type: 1, Code: 50, Value: 1
evbug.c: Event. Dev: isa0060/serio0/input0, Type: 0, Code: 0, Value: 0
evbug.c: Event. Dev: isa0060/serio0/input0, Type: 4, Code: 4, Value: 18
evbug.c: Event. Dev: isa0060/serio0/input0, Type: 1, Code: 18, Value: 1
evbug.c: Event. Dev: isa0060/serio0/input0, Type: 0, Code: 0, Value: 0
evbug.c: Event. Dev: isa0060/serio0/input0, Type: 4, Code: 4, Value: 50
evbug.c: Event. Dev: isa0060/serio0/input0, Type: 1, Code: 50, Value: 0

-- Now my network name resolution is not working. I can ping using IP addresses.

-- Xen is dropping 1GB memory of 4 GB!!! (see attached xm_dmesg)
 Xen version 3.0.3-rc4  (root@) (gcc version 4.1.1 20060525 (Red Hat 4.1.1-1)) Thu Oct 12 22:58:53 PDT 2006
 Latest ChangeSet: Thu Oct 12 19:09:08 2006 +0100 11758:946628333c31

(XEN) Command line: /xen.gz dom0_mem=768000
(XEN) WARNING: Only the first 4 GB of the physical memory map can be accessed
(XEN)          by Xen in 32-bit mode. Truncating the memory map...
(XEN) Physical RAM map:
(XEN)  0000000000000000 - 000000000009f800 (usable)
(XEN)  000000000009f800 - 00000000000a0000 (reserved)
(XEN)  00000000000f0000 - 0000000000100000 (reserved)
(XEN)  0000000000100000 - 00000000bbff0000 (usable)
(XEN)  00000000bbff0000 - 00000000bbff3000 (ACPI NVS)
(XEN)  00000000bbff3000 - 00000000bc000000 (ACPI data)
(XEN)  00000000f0000000 - 00000000f2000000 (reserved)
(XEN)  00000000fec00000 - 0000000100000000 (reserved)
(XEN) System RAM: 3007MB (3079740kB)
(XEN) Xen heap:  10MB (10376kB)(XEN) PAE disabled.
(XEN) found SMP MP-table at 000f5240
(XEN) DMI 2.3 present.
(XEN) Using APIC driver default
(XEN) ACPI: RSDP (v000 GBT                                   ) @ 0x000f6bf0
(XEN) ACPI: RSDT (v001 GBT    AWRDACPI 0x42302e31 AWRD 0x01010101) @ 0xbbff3000
(XEN) ACPI: FADT (v001 GBT    AWRDACPI 0x42302e31 AWRD 0x01010101) @ 0xbbff3040
(XEN) ACPI: SSDT (v001 PTLTD  POWERNOW 0x00000001  LTP 0x00000001) @ 0xbbff7a40
(XEN) ACPI: MCFG (v001 GBT    AWRDACPI 0x42302e31 AWRD 0x01010101) @ 0xbbff7c80
(XEN) ACPI: MADT (v001 GBT    AWRDACPI 0x42302e31 AWRD 0x01010101) @ 0xbbff79c0
(XEN) ACPI: DSDT (v001 GBT    AWRDACPI 0x00001000 MSFT 0x0100000c) @ 0x00000000
(XEN) ACPI: Local  APIC address 0xfee00000
(XEN) ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
(XEN) Processor #0 15:11 APIC version 16

============  BUILD PROCEDURE ===================
# cd /usr/src/
# hg clone http://xenbits.xensource.com/xen-3.0.3-testing.hg
# cd xen-3.0-3testing.hg
# make world
# make install
# mkinitrd initrd.img-
# ln -sf initrd.img- initrd.img-2.6-xen

--- disabled ASUS-ACPI
# make linux-2.6-xen-config CONFIGMODE=menuconfig
# make linux-2.6-xen-build
# make linux-2.6-xen-install

-- did the whole procedure twice.. once skipped this two
--- steps (removed and rebuilt, as mkinitrd was
# rm initrd.img-
# mkinitrd initrd.img-

I had to manually copy xen and grub from /usr/lib/python to /usr/lib/python2.4/site-packages.
Added a new entry in the menu.lst under

title Fedora Core TEST (
        root (hd0,0)
        kernel /xen.gz dom0_mem=768000
        module /vmlinuz- ro root=/dev/VG_Fedora/LV2 rhgb quiet
        module /initrd.img-

booted in Test kernel. And tried to create HVM winxp domu.

Keir Fraser <Keir.Fraser@xxxxxxxxxxxx> wrote:
Re: [Xen-devel] RE: [Xen-users] HVM WinXP dom crash     On 9/10/06 8:19 pm, "jdsw" <jdsw2002@xxxxxxxxx> wrote:
ok.. I would not worry about the WRMSR warnings.
 But how do I get pass the ROMBIOS problem ?
 ccing devloper forum,in case someone knows about this  particular issue.

 The hvmloader binary is definitely out of sync with the Xen binary (hvmloader?s SVM hypercall interface is older than the Xen that you are running knows about). This might be a misfeature of the FC5 packages, although I haven?t heard anyone else report this problem.
 If you want to play with the best-possible bits right now, particularly for HVM guests, I recommend you download binary tarballs when we release 3.0.3-final in a few days, or grab the xen-3.0.3-testing.hg repository and build it yourself. Then you?ll know for sure that everything is in sync.
  -- Keir


Get your email and more, right on the  new Yahoo.com <http://us.rd.yahoo.com/evt=42973/*http://www.yahoo.com/preview>   


Want to be your own boss? Learn how on  Yahoo! Small Business. <http://us.rd.yahoo.com/evt=41244/*http://smallbusiness.yahoo.com/r-index>  

Talk is cheap. Use Yahoo! Messenger to make PC-to-Phone calls. Great rates starting at 1¢/min.
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.