This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] dev/xen/evtchn disappears, HVM fails, xen 4.0.1-1 Debian

To: Erik Hjelmås <erik.hjelmas@xxxxxxxxx>
Subject: Re: [Xen-users] dev/xen/evtchn disappears, HVM fails, xen 4.0.1-1 Debian Squeeze
From: "Fajar A. Nugraha" <list@xxxxxxxxx>
Date: Mon, 20 Sep 2010 09:43:00 +0700
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Sun, 19 Sep 2010 19:43:44 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <AANLkTi=crJc8t4iJZ3Jja3nFDz4fdOfZc-RqDEtwAYcH@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <AANLkTi=crJc8t4iJZ3Jja3nFDz4fdOfZc-RqDEtwAYcH@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
2010/9/19 Erik Hjelmås <erik.hjelmas@xxxxxxxxx>:
> Hi,
> (forgive me if this should be sent to a Debian list since the problem might
> be Debian specific)

You should definitely ask there as well.

> my server running xen 4.0.1 and Debian Squeeze (with all the xen 4.0.1
> debian packages, everything installed using aptitude) was working fine for
> PV and HVM guest until an aptitude upgrade on Monday,

Was it also 4.0.1, or 4.0.0 (before aptitude upgrade)?

> zimbu:/home/erikh# dpkg -l | grep xen
> libxenstore3.0                      4.0.1-1
> linux-image-2.6.32-5-xen-amd64      2.6.32-21
> xen-hypervisor-4.0-amd64            4.0.1-1
> xen-linux-system-2.6.32-5-xen-amd64 2.6.32-21
> xen-qemu-dm-4.0                     4.0.1-1
> xen-tools                           4.2~rc1-1
> xen-utils-4.0                       4.0.1-1
> xen-utils-common                    4.0.0-1
> xenstore-utils                      4.0.1-1

AFAIK you usually need a matching version of hypervisor and tools.
Your tools version says 4.2~rc1-1, while hypervisor is 4.0.1-1. That
might be the cause.


Xen-users mailing list