This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] GPLPV uninstaller

To: <xen-users@xxxxxxxxxxxxxxxxxxx>, "Xen-devel" <xen-devel@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-devel] GPLPV uninstaller
From: "James Harper" <james.harper@xxxxxxxxxxxxxxxx>
Date: Sat, 16 May 2009 14:47:57 +1000
Delivery-date: Fri, 15 May 2009 21:48:24 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcnV4XucbOywOwS3QxSPsUwzF9Dwmw==
Thread-topic: GPLPV uninstaller
I've just uploaded a couple of .bat files to
http://www.meadowcourt.org/downloads/gplpv_uninstall_bat.zip that will
manually (and forcibly) uninstall GPLPV from your computer, which seems
to be necessary before doing upgrades from some versions. Run the
uninstaller, reboot, then install. There is a 0.9.x and a 0.10.x
uninstaller, which differ slightly, but the basic steps performed are:

. stop the shutdownmon service
. remove the %ProgramFiles%\Xen PV Drivers directory and all contents
. delete all files matching %SystemRoot%\system32\drivers\xen*
. delete any oem*.inf and oem*.pnf files from %SYSTEMROOT%\INF that
contain the text 'xen'
. delete all HKLM\SYSTEM\CurrentControlSet\Services\Xen* from the
. delete all references to 'xenhide' as a filter in the registry

I haven't tested the 0.9.x version in a little while but it worked last
time I tried it. After running the 0.10.x uninstaller on a system with installed, then rebooting, then installing, I found
that the network driver didn't work until the next reboot, at which
point it asked to be installed and then worked fine. Not sure why yet.


Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>