This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] "Cannot find root device" while initializing dom0

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] "Cannot find root device" while initializing dom0
From: Dominic Mason <dominic@xxxxxxxxxx>
Date: Wed, 29 Apr 2009 12:05:55 +0100
Delivery-date: Wed, 29 Apr 2009 04:26:14 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <f8c46d190904271224k147e5e37hea55210c846e93c1@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Organization: Opus VL
References: <f8c46d190904271224k147e5e37hea55210c846e93c1@xxxxxxxxxxxxxx>
Reply-to: dominic@xxxxxxxxxx
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
On Mon, 2009-04-27 at 16:24 -0300, Paolo Victor wrote:

> "Gave up waiting for root device. ALERT! /dev/by-uuid/xxxx does not
> exist"
> And boots the recovery shell. I've tried both compiling Xen and Dom0
> from source (Xen 3.3.1, kernel and using Ubuntu's
> packages (Xen 3.3, kernel 2.6.24-32-xen), with no luck. Native Ubuntu
> 8.10 boots normally, though, and the menu.lst's device UUIDs are
> correct.
This sounds very much like the problem I reported with a certain FoxConn
Motherboard, in which Xen only recognises onboard SATA when when I
reconfigured the BIOS to run in RAID mode, rather than the default IDE

> At the recovery shell, I can see that none of the /dev/sd* devices
> aren't listed, as expected, but the some drivers were loaded,
> according to the /proc/modules file:
> -libata
> -pata_api
> -pata_it8213
> -ata_generic
What I also tried was making sure that all the required SATA modules
were compiled into the kernel rather than as modules. This did not work,
either, until I tried the BIOS fix mentioned above as a matter of

> What do you think about this? Have any of you ever come across such
> problem? I'm thinking about trying a clean install on an IDE drive,
> but that would really be the last resort.
Well, I had Xen on an IDE drive in the same computer and although the
host OS could see (and boot from) the SATA drives, as soon as I booted
xen 3.3.1 no SATA drives, until I changed the BIOS.

for my other post with this problem.

Dominic Mason <dominic@xxxxxxxxxx>
Opus VL

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>