This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] "Cannot find root device" while initializing dom0

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] "Cannot find root device" while initializing dom0
From: Paolo Victor <paolovictor@xxxxxxxxx>
Date: Mon, 27 Apr 2009 16:24:48 -0300
Delivery-date: Mon, 27 Apr 2009 12:25:50 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:from:date:message-id :subject:to:content-type; bh=hjmX5ftSCdoFXbIP1JKPzD8wibIFG+AZtOhka3T+n3A=; b=E7CYPpSJrN4B4Oc9wSr+klOlVLouvXvs/57JkVCth5etKSIYE+/kw4+lfEAfNrXQxg pWrdl+EW3cUYroYzb/BIdoiZUscIudvdSG4FHASUKXEfYF3nWEdpd7Bck5bWY9Dyz4ru NGiAZBdzIlGRUdMPGBXVe4/nRr2bIKmK2V1DE=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:from:date:message-id:subject:to:content-type; b=j1B91PO3nqZDOrlvmDEVUKO/yXcMJrauRAi+oDmkXCYU6f7AUhvyXhUYG5HcSwrCwB L8fG1oczQ3RwELvp1EwEj+TgYRpLwh8D0yedoBnAp2liDCVkbQ8biV5so4bHV+puXZ4b 7DnHemnvZI9XG69uru2JdlwfQsxZ9WEZxPYt8=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx

I've been trying to install Xen 3.3, but when it tries to boot Dom0 it displays the message:

"Gave up waiting for root device. ALERT! /dev/by-uuid/xxxx does not exist"

And boots the recovery shell. I've tried both compiling Xen and Dom0 from source (Xen 3.3.1, kernel and using Ubuntu's packages (Xen 3.3, kernel 2.6.24-32-xen), with no luck. Native Ubuntu 8.10 boots normally, though, and the menu.lst's device UUIDs are correct.

The system I'm trying to install Xen has a x86_64 processor and 4 SATAII hard drives. I've read somewhere (sorry, I couldn't find it again) that Xen could have issues on waiting the hard drives to "spin up", so I tried setting the kernel's rootdelay option up to 480, but it didn't work either. I also tried disabling the other 3 hds that didn't contain the root partition.

At the recovery shell, I can see that none of the /dev/sd* devices aren't listed, as expected, but the some drivers were loaded, according to the /proc/modules file:


What do you think about this? Have any of you ever come across such problem? I'm thinking about trying a clean install on an IDE drive, but that would really be the last resort.

Thanks in advance for your attention,
Paolo Victor
Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>