This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] domU custom kernel: Kernel panic - not syncing: No init foun

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] domU custom kernel: Kernel panic - not syncing: No init found. Try passing init= option to kernel.
From: Alveox Services <alveox@xxxxxxxxxx>
Date: Sat, 25 Apr 2009 16:07:13 +0200
Delivery-date: Sat, 25 Apr 2009 07:08:13 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (Windows/20090302)

To compile a custom kernel, I downloaded from kernel.org and followed the tutorial at: http://wiki.xensource.com/xenwiki/Kernel.org_Linux_on_Xen

Used a supposedly working .config file for the compilation (generated by my provider to compile his xenU kernels), set /dev/xvd* device nodes both in the domU conf file (disk, root):

disk = [ 'phy:/dev/mapper/alveox-fhsslash,/dev/xvdb1,w', 'phy:/dev/mapper/alveox-fhsswap,xvdb2,w' ]
root = "/dev/xvdb1"

and its /etc/fstab:

proc /proc proc defaults 0 0
/dev/xvdb1 / reiserfs defaults 0 1
/dev/xvdb2 none swap sw 0 0

When booting the VM, I get a kernel panic at this point:
ReiserFS: xvdb1: found reiserfs format "3.6" with standard journal
ReiserFS: xvdb1: using ordered data mode
ReiserFS: xvdb1: journal params: device xvdb1, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: xvdb1: checking transaction log (xvdb1)
ReiserFS: xvdb1: replayed 9 transactions in 1 seconds
ReiserFS: xvdb1: Using r5 hash to sort names
ReiserFS: xvdb1: Removing [190 26878 0x0 SD]..done
ReiserFS: xvdb1: Removing [190 26872 0x0 SD]..done
ReiserFS: xvdb1: Removing [190 26845 0x0 SD]..done
ReiserFS: xvdb1: Removing [190 26804 0x0 SD]..done
ReiserFS: xvdb1: Removing [190 26797 0x0 SD]..done
ReiserFS: xvdb1: There were 5 uncompleted unlinks/truncates. Completed
VFS: Mounted root (reiserfs filesystem) on device 202:17.
Freeing unused kernel memory: 268k freed
Kernel panic - not syncing: No init found. Try passing init= option to kernel.

Cannot figure why its not booting. It seems to find and mount root correctly....
When I mount the filesystem manually, /sbin/init appears there.

Tried it with 3 different kernels from kernel.org:,, --> same error.

Problem does not seem to come from the dom0, when I use the kernel provided by my provider, the same filesystems are mounted just fine, the VM boots, here is what I get instead of the kernel panic:

VFS: Mounted root (reiserfs filesystem).
Freeing unused kernel memory: 256k freed
INIT: version 2.86 booting

Any help, or pointers where the problem may come from, appreciated....



Xen-users mailing list