This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Dom U stuck at boot time- centos.5-2 domU image on RHEL

On Tue, Apr 21, 2009 at 4:20 AM, Ata E Husain Bohra
<aehusain@xxxxxxxxxxx> wrote:
> Dear Fajar,
> I tried your suggestion, but there are more interesting observations. If I
> edit my config file to include extra ="3 xencons=tty", the domU still hangs

probably because of this

> WARNING: Failed to register Xen virtual console driver as 'tty1'

> Then I tried to google more and found a web link which was about centos (but
> worked for ubuntu too),
> http://www.howtoforge.com/create-centos5.2-domu-on-ubuntu-hardy-dom0
> It instructs to edit the initab (event.d/tty1 in ubuntu) to make runlevel1
> thread to respwan with argument as "console" than "tty1". I also had to
> remove
> "extra" argument from the xen config file. With these two changes I am able
> to get to the login prompt.
> Please share if there is a reason for this behavior.

Had you read the link I set you thoroughly, you'd have seen my
suggestion on that thread. This message in particular should answer
your question


It seems that you can replace "xvc0" with "console" and get the same
result (at least on Centos).
In Ian's case, he prefer to add "xencons=tty" (which worked for him),
while in your case editing xencons didn't work. Probably
distro-specific issue (suse vs RHEL/Centos).



Xen-users mailing list