This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] intermittent domU issue: related to udev?

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] intermittent domU issue: related to udev?
From: Eric Lenio <eric@xxxxxxxxx>
Date: Sun, 19 Apr 2009 10:31:09 -0400
Delivery-date: Sun, 19 Apr 2009 07:31:53 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.17+20080114 (2008-01-14)
Hello list.  My server:

Gentoo 2.6.21-xen dom0
xen-tools 3.2.1
lvm 2.02.28-r2

Symptoms: normally I run 4 domUs.  About once a week I have a need to
restart a domU.  Sometimes it works just fine, but other times it does
not and I'll get a message back saying "Error: Device 0 (vif) could not
be connected. Hotplug scripts not working".  The domU config file has
not been changed so I'm fairly certain it is configured properly.  I
think it comes down to the domU not being able to "talk" with udevd.  I
know udevd is still running and is responsive (if I run udevmonitor and
mount/umount a disk I see normal output).  When I attempt to start my
domU I normally see udevmonitor output like this:

UEVENT[1240149226.992189] add      /devices/xen-backend/vbd-9-2048 (xen-backend)
UDEV  [1240149226.993163] add      /devices/xen-backend/vbd-9-2048 (xen-backend)
UEVENT[1240149227.012202] add      /devices/xen-backend/vbd-9-2064 (xen-backend)
UDEV  [1240149227.013301] add      /devices/xen-backend/vbd-9-2064 (xen-backend)
UEVENT[1240149227.045410] add      /devices/xen-backend/vif-9-0 (xen-backend)
UDEV  [1240149227.048638] add      /devices/xen-backend/vif-9-0 (xen-backend)
UEVENT[1240149227.051320] add      /devices/virtual/net/vif9.0 (net)
UEVENT[1240149227.051805] online   /devices/xen-backend/vif-9-0 (xen-backend)
UDEV  [1240149227.054369] online   /devices/xen-backend/vif-9-0 (xen-backend)
UDEV  [1240149227.062738] add      /devices/virtual/net/vif9.0 (net)
UEVENT[1240149227.108918] add      /devices/xen-backend/console-9-0 
UDEV  [1240149227.110112] add      /devices/xen-backend/console-9-0 

But when the issue happens I see no udevmonitor output.  Restarting
udevd did not help.  The problem does not seem specific to any
particular domU -- once the condition happens, none of the domUs will
restart.  My only solution so far has been to restart dom0.

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] intermittent domU issue: related to udev?, Eric Lenio <=