This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] tap:aio not working...

To: Gernot Kieseritzky <gernotk@xxxxxxxxx>
Subject: Re: [Xen-users] tap:aio not working...
From: Marcel Ritter <Marcel.Ritter@xxxxxxxxxxxxxxxxxxxx>
Date: Wed, 30 Apr 2008 13:38:38 +0200
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Wed, 30 Apr 2008 04:37:01 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <48185299.3060508@xxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <E1Jr9wu-0007tJ-9g@host-192-168-0-1-bcn-london> <48185299.3060508@xxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20080226)
Gernot Kieseritzky schrieb:

Nick Couchman schrieb:
I'm running SLES10 SP1 and have been using file:/ for my file-backed domUs.  
The domUs sit on a shared OCFS2 SAN-backed filesystem and are run on my three 
or four XEN servers.  I'm having issues with the loopback devices not being 
released when the domUs shutdown or migrate, so I decided to switch over to 
tap:aio for my file-backed domUs.  This isn't working, either.  Whereas the 
domUs with file: at least boot and run, the domUs with tap:aio: fail with this 
Hi Nick,

we're running quite some Xen machines on SLES 10 SP1 here, too.
I tried to switch from file:/ to tap:aio:/ (as xen documentation recommends),
without success. As far as I can see the creation itself works, but it locks
down the machine shortly after accessing it.

For now I do my testing on Dom0 (it's easier to see what's happening there).
So here's what I tried:

# Create 2 TB sparse file
linux # dd if=/dev/zero of=/proj.stand/xen/disk2 bs=1M count=1 seek=2048000
1+0 records in
1+0 records out
1048576 bytes (1,0 MB) copied, 0,018314 seconds, 57,3 MB/s

# Attach it to dom0 as /dev/hdb
linux # xm block-attach 0 tap:aio:/proj.stand/xen/disk2 /dev/hdb  w 0
linux # cat /proc/partitions
   3    64 2097153024 hdb

Now fdisk/mount this device - whatever you like.

During my test the machine froze quite fast, however the same tests with file:/
work quite well - no idea why.

Someone on the list, where this works?

Have you checked that the process "blktapctrl" is running on dom0 (ps ax
| grep blktapctrl)? If not, than your Kernel might be compiled without
blktap support. I'm using Xen with Debian-Etch in dom0 and the debian
xen-kernel has blktap-support disabled by default so I had to build a
custom kernel.

Yepp, should be compiled in: process is running, modules loaded:

linux7:~ # ps -ef | grep blkta
root 3735 1 0 Apr23 ? 00:00:00 blktapctrl
root 15395 15326 0 13:34 pts/9 00:00:00 grep blkta
linux7:~ # lsmod | grep blktap
blktap 124804 2 [permanent]
xenbus_be 8576 3 netbk,blkbk,blktap
Gernot Kieseritzky

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>