This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] tap:aio not working...

To: Nick Couchman <Nick.Couchman@xxxxxxxxx>
Subject: Re: [Xen-users] tap:aio not working...
From: Marcel Ritter <Marcel.Ritter@xxxxxxxxxxxxxxxxxxxx>
Date: Wed, 30 Apr 2008 12:35:32 +0200
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Wed, 30 Apr 2008 03:33:37 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <48175653.87A6.0099.1@xxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <48175653.87A6.0099.1@xxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20080226)
Nick Couchman schrieb:
I'm running SLES10 SP1 and have been using file:/ for my file-backed domUs.  
The domUs sit on a shared OCFS2 SAN-backed filesystem and are run on my three 
or four XEN servers.  I'm having issues with the loopback devices not being 
released when the domUs shutdown or migrate, so I decided to switch over to 
tap:aio for my file-backed domUs.  This isn't working, either.  Whereas the 
domUs with file: at least boot and run, the domUs with tap:aio: fail with this 
Hi Nick,

we're running quite some Xen machines on SLES 10 SP1 here, too.
I tried to switch from file:/ to tap:aio:/ (as xen documentation recommends),
without success. As far as I can see the creation itself works, but it locks
down the machine shortly after accessing it.

For now I do my testing on Dom0 (it's easier to see what's happening there).
So here's what I tried:

# Create 2 TB sparse file
linux # dd if=/dev/zero of=/proj.stand/xen/disk2 bs=1M count=1 seek=2048000
1+0 records in
1+0 records out
1048576 bytes (1,0 MB) copied, 0,018314 seconds, 57,3 MB/s

# Attach it to dom0 as /dev/hdb
linux # xm block-attach 0 tap:aio:/proj.stand/xen/disk2 /dev/hdb  w 0
linux # cat /proc/partitions
  3    64 2097153024 hdb

Now fdisk/mount this device - whatever you like.

During my test the machine froze quite fast, however the same tests with file:/
work quite well - no idea why.

Someone on the list, where this works?

Error: Device 51952 (vbd) could not be connected. Hotplug scripts not working.
I've searched the mailing lists and been through all the udev issues, and none of those seem to apply - my loop devices and vifs are connecting perfectly fine, just these tap:aio devices that won't work. I've also verified that blktap and xenblk are loaded as modules. I used udevmonitor to track what happens when I start domUs with tap:aio vs. file (loop) disks. Here's file method: UEVENT[1209507940.668013] add@/block/dm-30
UEVENT[1209507940.668040] offline@/block/dm-30
UEVENT[1209507940.668049] online@/block/dm-30
UEVENT[1209507940.668059] add@/block/dm-31
UEVENT[1209507940.668067] offline@/block/dm-31
UEVENT[1209507940.668074] online@/block/dm-31
UDEV  [1209507940.895265] add@/block/dm-31
UDEV  [1209507940.896125] offline@/block/dm-31
UDEV  [1209507940.949818] online@/block/dm-31
UDEV  [1209507940.951980] add@/block/dm-30
UDEV  [1209507940.952814] offline@/block/dm-30
UEVENT[1209507940.962962] mount@/block/dm-30
UDEV  [1209507940.979895] online@/block/dm-30
UDEV  [1209507940.980777] mount@/block/dm-30
UEVENT[1209507941.415122] umount@/block/dm-30
UDEV  [1209507941.415413] umount@/block/dm-30
UEVENT[1209507941.421063] remove@/block/dm-30
UEVENT[1209507941.422222] remove@/block/dm-31
UDEV  [1209507941.422598] remove@/block/dm-30
UDEV  [1209507941.423304] remove@/block/dm-31
UEVENT[1209507942.248473] add@/devices/xen-backend/vkbd-15-0
UDEV  [1209507942.248767] add@/devices/xen-backend/vkbd-15-0
UEVENT[1209507942.255938] add@/devices/xen-backend/vfb-15-0
UDEV  [1209507942.256133] add@/devices/xen-backend/vfb-15-0
UEVENT[1209507942.272675] add@/devices/xen-backend/vbd-15-51712
UEVENT[1209507942.297785] add@/devices/xen-backend/vif-15-0
UDEV  [1209507942.298036] add@/devices/xen-backend/vif-15-0
UEVENT[1209507942.301038] add@/class/net/vif15.0 UEVENT[1209507942.301052] online@/devices/xen-backend/vif-15-0
UEVENT[1209507942.374108] add@/devices/xen-backend/console-15-0
UDEV  [1209507942.374558] add@/devices/xen-backend/console-15-0
UDEV  [1209507942.404498] online@/devices/xen-backend/vif-15-0
UDEV [1209507942.459501] add@/class/net/vif15.0 UDEV [1209507942.616792] add@/devices/xen-backend/vbd-15-51712
and here's tap:aio method:
UEVENT[1209507805.006622] add@/devices/xen-backend/vbd-0-51952
UEVENT[1209507805.007163] add@/devices/xen/vbd-51952
UDEV  [1209507805.007937] add@/devices/xen/vbd-51952
UDEV  [1209507805.042766] add@/devices/xen-backend/vbd-0-51952
UEVENT[1209507905.016513] remove@/devices/xen-backend/vbd-0-51952
UEVENT[1209507905.067583] remove@/devices/xen/vbd-51952
UDEV  [1209507905.067852] remove@/devices/xen/vbd-51952
UDEV  [1209507905.078662] remove@/devices/xen-backend/vbd-0-51952
syslog messages are unhelpful - here's the output when I try with tap:aio:
Apr 29 16:55:02 xen02 kernel: blkback: ring-ref 8, event-channel 38, protocol 1 
Apr 29 16:55:02 xen02 kernel: blkback: ring-ref 8, event-channel 38, protocol 1 
Apr 29 16:55:02 xen02 logger: /etc/xen/scripts/block: add 
Apr 29 16:56:42 xen02 logger: /etc/xen/scripts/block: remove 
Apr 29 16:56:43 xen02 logger: /etc/xen/scripts/xen-hotplug-cleanup: 
Anyone have any hints as to what might be going on here? Any possible solutions? Thanks,
P.S. - FWIW, it doesn't seem to make a difference whether the files are local vs. SAN as to whether tap:aio works or not.

This e-mail may contain confidential and privileged material for the sole use 
of the intended recipient.  If this email is not intended for you, or you are 
not responsible for the delivery of this message to the intended recipient, 
please note that this message may contain SEAKR Engineering (SEAKR) 
Privileged/Proprietary Information.  In such a case, you are strictly 
prohibited from downloading, photocopying, distributing or otherwise using this 
message, its contents or attachments in any way.  If you have received this 
message in error, please notify us immediately by replying to this e-mail and 
delete the message from your mailbox.  Information contained in this message 
that does not relate to the business of SEAKR is neither endorsed by nor 
attributable to SEAKR.

Xen-users mailing list

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>