This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Time freeze in domU after reboot

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Time freeze in domU after reboot
From: "Krzysztof A. Adamski" <mr-k@xxxxx>
Date: Tue, 29 Apr 2008 14:30:26 +0200
Delivery-date: Tue, 29 Apr 2008 05:38:14 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Hi, I'm running some Xen systems with CentOS 5.1 on dom0 (latest
2.6.18-53.1.14.el5xen kernel, xen-3.0.3-41.el5). I have the problem
that after rebooting machine (with shutdown -r now) the time in domUs
(CentOS 5.1 or Fedora 8 installed using virt-install) that are
automatically started is frozen (i mean it stops, when I run 'date'
multiple times you always get the same result). This makes a lot of
problems because all sleeps takes forever so processes are hanging. I
can't even shut them out, the only solution is to use 'xm destroy'.

What i've found out so far is that /etc/init.d/xendomains script is
using 'xm pause' when stopping and 'xm restore' when starting. This
means that all active domUs are paused just before reboot and restored
when system is started. Indeed, doing the same manualy gives the same
issue. I can pause and restore domUs as many times as I wan't and it
works great but only if I won't reboot machine between pause and

I have this problem on many different machines (from AMD Duron 1200 to
Intel Quad Core 2). The only workaround I've found is to
force /etc/init.d/xendomains script not to pause but shutdown machines
when stopping. But i consider my problem as a bug in Xen. Am I the only
one having this issue? Is this known issue?

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] Time freeze in domU after reboot, Krzysztof A. Adamski <=