This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


solved, Re: [Xen-users] Windows domU doesn't boot

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: solved, Re: [Xen-users] Windows domU doesn't boot
From: Michael Jinks <mjinks@xxxxxxxxxxxx>
Date: Fri, 25 Apr 2008 03:19:12 -0500
Delivery-date: Fri, 25 Apr 2008 01:19:49 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <20080425021204.GF10366@xxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <20080425021204.GF10366@xxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.13 (2006-08-11)
Following up to myself in case anybody else finds any of it useful:

On Thu, Apr 24, 2008 at 09:12:04PM -0500, Michael Jinks wrote:
> The symptoms: when I create the domain, I don't get any errors at the
> command line, and I'm not sure if I'm seeing errors in xend.log or not,
> but the domain never does anything.  The console doesn't appear (have
> tried all sorts of different config syntaxes for vnc and sdl -- again,
> so many different forms appear around the net that I don't know which
> ones are correct, but I'm borrowing from the working configs for my
> Linux domU's).  "xm list" shows straight dashes for the domU; no "r",
> no "b", no "c":
>  % sudo xm list loathsome
>  Name                                        ID   Mem VCPUs      State Time(s)
>  loathsome                                  175   512     1     ------ 0.0

Since posting this (and getting an example of a known good Windows xm
config file which didn't make any difference), I've discovered a few
things and gotten a little further.  First I noticed that the qemu-dm
logs for my Windows machine were tiny.  One complete example:

  % cat qemu-dm-177.log
  Watching /local/domain/0/device-model/177/logdirty/next-active
  Watching /local/domain/0/device-model/177/command
  warning: could not open /dev/net/tun: no virtual network emulation
  Could not initialize device 'tap'

I hadn't needed a tap interface for any of my Linux domains.  So I built
and installed the module for dom0, then had to modprobe it by hand. 
That got me past this error and on to:

  shift keysym 003e keycode 52
  shift keysym 003f keycode 53
  bind() failed

bind() of what failed?  Well, comparing this to the log for a working
Linux machine, the next thing after all the shift keysym/keycode lines
was "char device redirected to /dev/pts/12".  Right or wrong, that made
me think of serial lines.  My Windows config (but none of my Linux) had


...so I commented that out.  Now the qemu log still ends on an ugly
looking line:

  I/O request not ready: 0, ptr: 0, port: 0, data: 0, count: 0, size: 0

...but the Windows install CD has booted!  Hooray!  Now on to seeing if
I can turn this into a working system.

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>