This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Windows domU doesn't boot

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Windows domU doesn't boot
From: Michael Jinks <mjinks@xxxxxxxxxxxx>
Date: Thu, 24 Apr 2008 21:12:04 -0500
Delivery-date: Thu, 24 Apr 2008 19:12:40 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.13 (2006-08-11)
Hi, all.

I'm a Xen newbie, more or less.  I've got a Linux dom0 successfully
running two different flavors of Linux domU, now I'm trying for my first
HVM guest, a Windows 2003 Server machine.  I'll paste my config file
below; I've found so many conflicting docs scattered around the net that
I don't know if it has any obvious errors in it or not.

The symptoms: when I create the domain, I don't get any errors at the
command line, and I'm not sure if I'm seeing errors in xend.log or not,
but the domain never does anything.  The console doesn't appear (have
tried all sorts of different config syntaxes for vnc and sdl -- again,
so many different forms appear around the net that I don't know which
ones are correct, but I'm borrowing from the working configs for my
Linux domU's).  "xm list" shows straight dashes for the domU; no "r",
no "b", no "c":

 % sudo xm list loathsome
 Name                                        ID   Mem VCPUs      State Time(s)
 loathsome                                  175   512     1     ------ 0.0

The hardware is a brand new Sun Ultra40, with SVM-equipped AMD
processors.  dom0 kernel is the Gentoo package of Linux 2.6.21/xen, Xen
version is 3.2.0.

I have an LVM partition set up to act as the Windows hard drive.  Works
for my other domains... CD is an iso file which I've used successfully
to install Windows on VMware, so it should be kosher...

Thanks in advance for any clues.  Tips on where to get trustworthy docs
are also welcome; the Xen web site is nice so far as it goes, but there
are lots of gaps, unless I just don't know where to look.


-- begin domU config file, with comments --

builder = 'hvm'
kernel = '/usr/lib/xen/boot/hvmloader'
memory = '512'
device_model = '/usr/lib/xen/bin/qemu-dm'
disk = [ 'phy:/dev/mapper/pile-loathsome.uchicago.edu,ioemu:hda,w', 
'file:/xen/isos/server2003.iso,ioemu:hdc:cdrom,r' ]
name = 'loathsome'
vif = [ '' ]
boot = 'd'

# config lines which i've tried and rejected for one reason or another:

# disk = [ 'phy:/dev/mapper/pile-loathsome.uchicago.edu,ioemu:hda,w' ]

# cdrom='/xen/isos/server2003.iso'

# vfb = [ 'type=vnc, vncpasswd=l3m0n, vncunused=1, vnclisten=' ]
# vfb = [ 'type=vnc, vncpasswd=l3m0n, display=4, vnclisten=' ]

# some sites show a completely different approach to console configs:
# vnc = 1
# vncunused = 1
# display = 3
# vncviewer = 1  # <- what does the "vncviewer" directive mean, exactly?
# vncpasswd = 'l3m0n'
# vnclisten = 
# apic = 0
# acpi = 0
# sdl = 1  # <- i've seen accounts of people saying "sdl" worked better
           # than a vnc console; how does one connect to an "sdl"
           # console?  not from vncviewer, right...?

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>