This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] error when creating hvm guest with virt-manager

To: <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: RE: [Xen-users] error when creating hvm guest with virt-manager
From: "Ross S. W. Walker" <rwalker@xxxxxxxxxxxxx>
Date: Tue, 22 Apr 2008 10:07:09 -0400
Delivery-date: Tue, 22 Apr 2008 07:07:46 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
Importance: normal
In-reply-to: <VA.00003199.0b4e72b2@xxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Priority: normal
References: <VA.00003199.0b4e72b2@xxxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcikdmVY8PtB3OP2SMOUxpkTf6bhagAC0AzQ
Thread-topic: [Xen-users] error when creating hvm guest with virt-manager
Kai Schaetzl wrote:
> I suppose I need to apply some patch but can't find the right one.
> Xen 3.2 (the packages from xen.org) on CentOS 5.1
> I wanted to install my first hvm guest and wanted to use an old Suse 9.0 
> (of course, there are reasons why I wanted to use that ;-).
> First problem I encountered is that virt-manager blanked out the option to 
> install from cdrom. I copied the first CD with dd to an iso image and used 
> that as an install source. This gives me the following error:
> The error is "Unable to complete install 'libvirt.libvirtError 
> virDomainCreateLinux() failed POST operation failed. (xend.err 'Error 
> creating 
> domain: long() argument must be a string or a number')"
> Google finds only this single article, but I don't think I hit exactly the 
> same problem: http://article.gmane.org/gmane.comp.emulators.xen.user/33078
> The traceback I get does not touch XendDomainInfo.py, it starts in 
> create.py. Anyway, I changed the code in XendDomainInfo.py and tried again 
> with the same result. (I don't have the complete traceback on hand, 
> otherwise I would add it. If necessary I can get it again.)
> Someone suggested using qemu to startup the installation. This worked, 
> indeed, (with some twists) and I can now startup a xen hvm with the 
> installed system on that disk image. So, it really looks like just some 
> bug in the creation code of virt-manager.

The fix for this is in changeset 16764

I posted the patches and xen.spec file on centos-virt for this
and the HVM localtime problem. You should find them there.


This e-mail, and any attachments thereto, is intended only for use by
the addressee(s) named herein and may contain legally privileged
and/or confidential information. If you are not the intended recipient
of this e-mail, you are hereby notified that any dissemination,
distribution or copying of this e-mail, and any attachments thereto,
is strictly prohibited. If you have received this e-mail in error,
please immediately notify the sender and permanently delete the
original and any copy or printout thereof.

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>