This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] error when creating hvm guest with virt-manager

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] error when creating hvm guest with virt-manager
From: Kai Schaetzl <maillists@xxxxxxxxxxxxx>
Date: Tue, 22 Apr 2008 14:42:22 +0200
Delivery-date: Tue, 22 Apr 2008 05:43:10 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Reply-to: xen-users@xxxxxxxxxxxxxxxxxxx
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
I suppose I need to apply some patch but can't find the right one.

Xen 3.2 (the packages from xen.org) on CentOS 5.1

I wanted to install my first hvm guest and wanted to use an old Suse 9.0 
(of course, there are reasons why I wanted to use that ;-).

First problem I encountered is that virt-manager blanked out the option to 
install from cdrom. I copied the first CD with dd to an iso image and used 
that as an install source. This gives me the following error:

The error is
"Unable to complete install 'libvirt.libvirtError virDomainCreateLinux() 
failed POST operation failed. (xend.err 'Error creating domain: long() 
argument must be a string or a number')"

Google finds only this single article, but I don't think I hit exactly the 
same problem:

The traceback I get does not touch XendDomainInfo.py, it starts in 
create.py. Anyway, I changed the code in XendDomainInfo.py and tried again 
with the same result. (I don't have the complete traceback on hand, 
otherwise I would add it. If necessary I can get it again.)

Someone suggested using qemu to startup the installation. This worked, 
indeed, (with some twists) and I can now startup a xen hvm with the 
installed system on that disk image. So, it really looks like just some 
bug in the creation code of virt-manager.


Kai Schätzl, Berlin, Germany
Get your web at Conactive Internet Services: http://www.conactive.com

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>