This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] 3w-xxxx / 3ware 8006-2LP corruption issues using Xen ker

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] 3w-xxxx / 3ware 8006-2LP corruption issues using Xen kernel
From: Holm Kapschitzki <holm@xxxxxxxxxx>
Date: Tue, 22 Apr 2008 00:40:10 +0200
Delivery-date: Mon, 21 Apr 2008 15:42:29 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <480CF4B3.9040504@xxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <480CF4B3.9040504@xxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (Windows/20080213)
Bas Verhoeven schrieb:

I recently bought a new server with a 3Ware 8006-2LP controller to run
Xen on a Debian linux distribution:

- Server: ASUS RS120-E4/PA4
- Debian Release: etch
- Architecture: 32bit / 686
- Memory: 8 GB
- Disks: 2x Hitachi HDT725050VLA360
- Controller: 3ware 8006-2LP  (Driver Version =, Firmware
Version = FE8S, Bios Version = BE7X

it is nearly the same hardware/os i use

After seeing that I remembered the errors at the debootstrap process,
and tried running this process again: still the same errors after a few
days, with several different mirrors.

same thing

So it's definite: something is going wrong when writing data TO disk. As
said earlier, I have a 3ware controller in this system (3w-xxxx driver),
having two disks in RAID-1 and figured that if there was a broken disk,
the controller would notify me, but it claimed all disks were OK.
Removing a random disk from the controller did cause the array to be
degraded, but I could still reproduce the corruption issues. So it's not
some specific disk that is broken, unless both disks are, which is
highly unlikely.

look at my ealier post, i describe the same problem.


so i get the error with etch 32 bit / 64 bit, xen 3.1 / 3.2 , with 2.6.18 kernel xen , with gentoo kernel 2.6.20r6 xen. It wasnt all the time. But i have to reboot the maschine to get it solved for a while. So i testet it with ca. 5 machines, setup in different ways with other kernels.

I think i could be a kernel compile parameter? or via chipset in relation to 3ware raid controller?

Greets Holm

Xen-users mailing list