This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] No shared physical device in virt-manager

To: <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: RE: [Xen-users] No shared physical device in virt-manager
From: <joel.coopersmith@xxxxxxxxxxxxx>
Date: Thu, 10 Apr 2008 08:03:07 -0500
Delivery-date: Thu, 10 Apr 2008 06:11:27 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
Importance: normal
In-reply-to: <VA.0000313d.7bd490ba@xxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Priority: normal
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AciagM8E7npZGRtkR8SLWvxcE9oeFAAiW7bg
Thread-topic: [Xen-users] No shared physical device in virt-manager
        The patch you linked to solved my problem. Thanks very much for the 


-----Original Message-----
From: xen-users-bounces@xxxxxxxxxxxxxxxxxxx 
[mailto:xen-users-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Kai Schaetzl
Sent: Wednesday, April 09, 2008 3:31 PM
To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] No shared physical device in virt-manager

 wrote on Wed, 9 Apr 2008 12:56:37 -0500:

> For the installation, I followed the redhat PDF on setting up xen doms 
> and guests.  I downloaded (via yum) the xen and virt-manager packages 
> that are "native" to RH.
> When I try and create a new guest it seems to work fine until I get to 
> the networking devices.  When I tried using a virtual adapter instead 
> of a shared physical

Ahm, yes, I think this happens already with RH/CentOS 5.1, not with Xen 3.2. I 
mixed that up. See http://bugs.centos.org/view.php?id=2516 for a patch. This 
will help you with new VMs.

> it comes up as a subnet.
>  I am able to ping and communicate using the virtual adapter, but if I 
> try and change the virtual devices IP to anything other than the 
> subnet, no communication occurs.

libvirtd/dnsmasq get installed with 5.1. That combination provides DHCP and 
virtual networking for this subnet over a bridge called virbr0. You can just 
disable libvirtd (which also disables dnsmasq) if you want to use static ip 
Then simply change the vif lines in your existing VM config files to use the 
"xenbr0" bridge instead of "virbr0". Configure the static IP *in* your VM like 


Kai Schätzl, Berlin, Germany
Get your web at Conactive Internet Services: http://www.conactive.com

Xen-users mailing list

This message is for the designated recipient only and may contain privileged, 
proprietary, or otherwise private information.  If you have received it in 
error, please notify the sender immediately and delete the original.  Any other 
use of the email by you is prohibited.

Xen-users mailing list