This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] VNC server not launching

To: Henri Cook <henri@xxxxxxxxxxxxxxxxxxxxx>
Subject: Re: [Xen-users] VNC server not launching
From: Michael Brancato <mike@xxxxxxxxxxxxxxxx>
Date: Wed, 09 Apr 2008 20:37:29 -0400
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Wed, 09 Apr 2008 17:38:11 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <47FA5B8C.2020707@xxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <47FA5AA4.50705@xxxxxxxxxxxxxxxx> <47FA5B8C.2020707@xxxxxxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (Macintosh/20080213)
Well, this isn't a remote machine, but I don't have X installed. I do have libvncserver installed.

All I have configured in xend-config.sxp is (vnc-listen '') and (vncpasswd 'password'). I honestly didn't have the password configured before, but blank or not, it still doesn't start a VNC server.


Mike Brancato, CISSP

Henri Cook wrote:
Hi Michael,

Did you configure the VNC server in xend-config.sxp? Is it a remote
host, or are you in front of the machine?


*Henri Cook*
Orion Internet Services Ltd.
T: +44 (0) 7763 746208
E: henri@xxxxxxxxxxxxxxxxxxx

Company registration number: 6365589 (registered in England & Wales)

Michael Brancato wrote:
I'm trying to launch a pvm SXDE machine.  I recently upgraded to 3.2
via the Ubuntu Hardy packages and now I can't seem to get vnc to launch.

I want VNC to launch a server after boot but I'm currently stuck with
using the text console.  I have tried using vnc=1 as before, but there
are no vnc related log entries in xend.log to help me figure out why
the vnc server is not launching.  I have the libvncserver libraries,
etc installed.

Using vnc=1 and vncviewer=1 launches vncviewer with -listen but the
server never starts so vncviewer never launches a display.

I wanted to see if there are some common solutions that might work for
this.  If not then I can post entries from the xend.log, etc.  But so
far there are no errors being reported in xend.conf.  The domain
launches fine, but no VNC server is launched.


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>