This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] xen new throws python error

Daniel Kao wrote on Wed, 02 Apr 2008 12:30:48 -0700:

> I noticed that also.  It will read my "old" configuration files located in 
/etc/xen either using "xm create" to start a guest domain from the CLI/shell or 
the Virtual Machine Manager in GNOME.

Yes, xm create works like normal, but then you don't get the "advantages" of 
xenstore. I understood the scarce documentation about "xm new" to provide just 
that: add a domain to xenstore.

> All the new files created for new guests with Xen 3.2 are stored in 
/var/lib/xend/domains/ with a UID and a single config.sxp.  To start up a guest 
domain with the new config.sxp files, I use the following command from the 
> # xm create --config=/var/lib/xend/domains/UID/config.sxp

I created a file with

> For the old Python ones:
> # xm create guest_domain_name
> If the above doesn't work, this should (Note: this is for the old config 
> files):
> # xm create --defconfig=/etc/xen/guest_domain_config
> You can replace --config with -F and --defconfig with -f.

I tried that now with create instead of new. The results are "mixed" to say the 

xm create -f /etc/xen/news -n > /etc/xen/news.sxp

creates an sxp file format with a plain text line "using file blabla" in the 
line. So, you have to remove/comment that line before it works (actually, it 
doesn't work, see below).

xm create -F /etc/xen/news -n > /etc/xen/news.sxp

doesn't create any XML output, just that first line I mention above. I

In other words: it doesn't work at all.
Also, there's a bug in all the help output
-f=FILE, --defconfig=FILE
is not correct, what works is:
-f FILE, --defconfig=FILE
e.g. the - parameter still doesn't like =, it takes it as part of the path.

Well, now that I have created /etc/xen/lvmtest2.sxp I want to make use of it:
mambo:~ xm create --defconfig=/etc/xen/lvmtest2.sxp
Using config file "/etc/xen/lvmtest2.sxp".
Error: Errors were found at line 3 while processing /etc/xen/lvmtest2.sxp:
            (name lvmtest2)

So, what's wrong with that? It doesn't like the configuration it created by its 


Kai Schätzl, Berlin, Germany
Get your web at Conactive Internet Services: http://www.conactive.com

Xen-users mailing list