This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] SOLVED: domU freezes solid after startup -- why?

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] SOLVED: domU freezes solid after startup -- why?
From: Rich Wales <richw@xxxxxxxxx>
Date: Wed, 19 Dec 2007 17:17:08 -0800
Delivery-date: Wed, 19 Dec 2007 17:18:04 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <4766C714.3020102@xxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <380-220071211724520781@xxxxxxxxxxxxxx> <47661107.1040709@xxxxxxxxxxxxxxxxxxxx> <47662393.9080108@xxxxxxxxxxxx> <4766C714.3020102@xxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20071031 Thunderbird/ Mnenhy/
Following up on my earlier posting:

> See the attached console output.  This time, it froze on the third line
> from the end ("Setting the system clock.."); the last two lines of output
> happened after I did an "xm shutdown" on the domU.
> In case it matters, I'm trying to run Xen 3.1 on an Ubuntu 7.10 system
> (kernel = 2.6.22-14-xen).  The hardware is an AMD Athlon XP 2700+ with
> 2 GB of RAM.  The dom0 seems to run perfectly.

The domU was freezing up in /etc/rcS.d/S11hwclock.sh -- presumably while
trying to run /sbin/hwclock.

I mounted the domU's disk, added   HWCLOCKACCESS=no   to /etc/default/rcS
-- bypassing the clock setting code (presumably unnecessary, right?, since
the domU's clock is simply a reflection of the dom0's clock?) -- and the
domU comes up just fine now.

Rich Wales      ===      Palo Alto, CA, USA      ===     richw@xxxxxxxxx
http://www.richw.org   ===   http://en.wikipedia.org/wiki/User:Richwales

Xen-users mailing list