This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Xen 4.0.1 connecting to smbfs shares

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Xen 4.0.1 connecting to smbfs shares
From: Mark Williamson <mark.williamson@xxxxxxxxxxxx>
Date: Sun, 9 Dec 2007 03:15:23 +0000
Cc: wasting away <usuckadapp@xxxxxxxxx>
Delivery-date: Sat, 08 Dec 2007 19:16:12 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <14234081.post@xxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <14234081.post@xxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: KMail/1.9.6 (enterprise 0.20070907.709405)
Hi there,

Just a quick hint:

These mailing lists are mostly aimed at the Open Source version of Xen, so 
folks here and so knowledgeable about Xen{Express,Server,Enterprise}.

There are forums at http://forums.xensource.com which are dedicated to the 
commercial products, so you may want to ask your questions there.

However, I do have some ideas about your problem.

On Sunday 09 December 2007, wasting away wrote:
> I've just installed Xen 4.0.1 express
> i have been trying to mount a share of my ISOs to the installation with out
> luck.  This is what I've tried so far
> 1. Using Xen Center 4.0 for windows
>       Run the "new storage repository" wizard
>       Selected Windows File sharing
>       Added the share
>       With and without a username with admin rights (share is read only for
> everyone)
>       with and without -t smbfs option
>    all with the same result
>       "Unable to mount the directory specified in device configuration 
> requiest"
>    The console provides the error "smbfs: mount_data version 1919251317 is
> not supported"
> This indicates smbfs is not loaded
> 2. using console root execute
>       yum install smbfs
> after about 3 seconds it complets the install with the mesage "Nothing to
> do"
> So smbfs is installed, but it still doesn't work

So you're creating a share using XenCenter on Windows and then trying to mount 
it on a Linux box?

> 3. using the console root execute
>       xe-mount-iso-sr // -t smbfs -o
> username=administrator
> I get the same error
>       "smbfs: mount_data version 1919251317 is not supported"
> And that's all the dmesg errors report as well
> What am I missing here?
> PS i'm a realitive noob with linux and have spent about 16hrs trying to
> figure this out :-/

The "Nothing to do" that you're getting doesn't actually mean that the package 
is installed, yum does give that (unhelpful) error when the package doesn't 
exist at all.

Try running "yum install samba-client".  Does that help?


Dave: Just a question. What use is a unicyle with no seat?  And no pedals!
Mark: To answer a question with a question: What use is a skateboard?
Dave: Skateboards have wheels.
Mark: My wheel has a wheel!

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>