This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] jailtime machine doesn't boot. root=

To: xen-users <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] jailtime machine doesn't boot. root=
From: Vincent <vgrato@xxxxxxxxx>
Date: Fri, 7 Dec 2007 10:57:44 -0800
Delivery-date: Fri, 07 Dec 2007 10:58:33 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:to:subject:mime-version:content-type; bh=NgTwXT73lATtk/HbvNrPp9kG4QnAzjWWHyFZlOvKmcU=; b=biIidmC+OP2EKwqBhg0BrsHgSUa1YOngLjyRAC3bQzvzq+t9CYWvofELDwvB/ihHSiNCrSuYT9eL6abLMbi66T9Obl6BGqWEJ1qNxMKUSGZR64agmNbbOY8Sc8gS1/i2CGEvRtYXHfAkGY9shbX8y2uCOaXKLIFGSbo0+JmWHXA=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:mime-version:content-type; b=vZmiVyMi0vDh4QT7qi85pUk9IhEYI0P3grvPX2fvcKZDwEf72TTSZXraZMPS55sKcs0F28B37Q7Kn3j6E7CAVxQH8lEZTAJqpapw+Or7l8EFaplnE6HIPTBOP20evX37CMqaGqJRIFIo2kwk6/RIF22YrUC5V/hj1Eu2umJhDC8=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
when i run xm create centos.5-0.xen3.cfg -c i get the boot output from the machine, but it doesn't actually go to completion, as i get this error:

XENBUS: Device with no driver: device/vbd/2049
XENBUS: Device with no driver: device/vbd/2050
XENBUS: Device with no driver: device/vif/0
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
VFS: Cannot open root device "sda1" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

the .cfg looks like this:
kernel = "/boot/vmlinuz-2.6.18-8.el5xen"
memory = 256
name = "centos.5-0 "
vif = [ '' ]
dhcp = "dhcp"
disk = ['file:/xen/centos/centos.5-0.img,sda1,w', 'file:/xen/centos/centos.swap,sda2,w']
root = "/dev/sda1 ro"

I have seen some people with their root = option set to a /dev/hda1, but when i run that in the config it gives the same error but with hda1

any ideas?

    Vincent Grato
    cell: (760) 443-1389
Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>