This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] dom0's LVM partition in domU

To: "Markus Gerber" <markus@xxxxxxxxxxxxx>
Subject: Re: [Xen-users] dom0's LVM partition in domU
From: "Emre Erenoglu" <erenoglu@xxxxxxxxx>
Date: Thu, 6 Dec 2007 14:20:00 +0100
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Thu, 06 Dec 2007 05:20:52 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:references; bh=jWL+We1mDkZxQYc7ZxCLsjTzorlVInq4Wut4BW7CxII=; b=G+4Pln4LZ8GGs9/nPP4vf6Mwrbd8VKFUvecOUB0o3HkqrEVVIneGstBMk2eYHjtKUnkW5QUCobTDuhNN9QC/yxjkKLJ4Wn1K083IZk38drJ+Dw32rppkAQ9sdW3IIkqLCaQsXIpgq5wiF3p5EMCrsbK5qR8OLgEhjZoHGJsQQZs=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:references; b=trX50hfAa6VLaY9n2MKT9CkFV3mPBSje4pWLZpD94FufwFQCI4Z+JfELO52O2ANFl4hMx2eEzPGZc28O34jUHrfIzOLtv4/eBqJGxJMSnJTOukmstx8pjLxI81+WG1DZZf3Z34ipYn3ft7jp5EpKHtyNIi2gEFlNOncT0DdhxP4=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <DFAAD8D1-663A-4242-8F2C-2DDB2BA98F2C@xxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <6A2EB997-1378-42A7-8D55-D0B1A986BE0E@xxxxxxxxxxxxx> <fe9771a80712060113k740f652bh252e677284fedc5e@xxxxxxxxxxxxxx> <6F7D82CF-22B2-4A45-9359-42877488D24A@xxxxxxxxxxxxx> <fe9771a80712060208k3e72c5fy1bcbe0ae5bfee3bf@xxxxxxxxxxxxxx> <1BB0525F-0F51-4993-82A3-ECC1DE059BCC@xxxxxxxxxxxxx> <fe9771a80712060457m3116b538ybf22711d66abec8d@xxxxxxxxxxxxxx> <DFAAD8D1-663A-4242-8F2C-2DDB2BA98F2C@xxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Can you please give the output of the following command:

ls -la /dev/xv*

Are you using a PV domain or a HVM domain? (full or para virtualization?)


On Dec 6, 2007 2:17 PM, Markus Gerber < markus@xxxxxxxxxxxxx> wrote:
What I did so far:
- Added the LVM-partition to the dom1's config ('phy:/dev/mapper/data-share,xvda1,w') in dom0
- Added /dev/xvda1 /mnt/share ext3 defaults 0 1              to /etc/fstab in dom1

I still get the very same error while booting.

Are there more steps to do? Mounting /dev/mapper/data-share in dom0 works and i can copy files to it.


On 06.12.2007, at 13:57, Emre Erenoglu wrote:

As Sadique indicated, try using xvda instead of sda or hda.


On Dec 6, 2007 1:49 PM, Markus Gerber wrote:
Hello Emre,

These devices do not exist in dom1.

Can I create them manually? Or do I need to install additional packages.

Uups: I've just seen that there is a typo in my first post - dom1 is running Debian Etch and not Ubuntu. Sorry about that!

Thanks and regards,

On 06.12.2007, at 11:08, Emre Erenoglu wrote:


Does it really not exist or just not formatted?

mkfs.ext3 /dev/sda3

and instead of sda, I think you shall consider using xvda (if you're on a PV domU or HVM with PV drivers)

can you see these devices in /dev?


On Dec 6, 2007 10:51 AM, Markus Gerber <markus@xxxxxxxxxxxxx> wrote:

Thank you for your tipp. Unfortunatly, I get an error when booting dom1 saying:

Loading device-mapper support.
Checking file systems...fsck 1.40-WIP (14-Nov-2006)
fsck.ext3: No such file or directory while trying to open /dev/sda3
The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

fsck died with exit status 8
failed (code 8).
* File system check failed. 

In my dom1's config file I added the last 'phy' to the disk
disk = [ 'phy:data/dom1-disk,sda1,w', 'phy:data/dom1-swap,sda2,w', 'phy:/dev/mapper/data-share,sda3,w' ]

How does the /etc/fstab in dom1 has to look like? I added:
/dev/sda3 /mnt/share ext3 defaults 0 1

With the line above it does not work. /dev/sda3 does not exist.

Thank you for some more hints.


On 06.12.2007, at 10:13, Emre Erenoglu wrote:

Just a disk= line would suffice. example:

disk = [ 'phy:/dev/volume-group/volume-name,hda1,w' , 'phy:/dev/md1,hda2,w' , 'phy:/dev/volume-group/volume-2,hda3,w' ]

/dev/volume-group/volume-name being one of your LVM volume. (or /dev/mapper/volume_group-volume_name



On Dec 6, 2007 9:37 AM, Markus Gerber < markus@xxxxxxxxxxxxx> wrote:

In my dom0 (Ubuntu 7.10) I have several LVM partitions (for mp3s,
photos, ...).
Since I do not want to have any services in dom0, I have a domU (also
Ubuntu 7.10) with Samba. So my users connect to that domU. How can I
export and import these LVM partitions from dom0 into domU?

Using nfs could work, but I prefer a solution where my LVM partitions
are 'natively' in domU.

Thank you for some hints and tipps.

Xen-users mailing list

Emre Erenoglu

Emre Erenoglu

Emre Erenoglu

Emre Erenoglu
Xen-users mailing list