This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] SDL makes me crazy (AARHHRG!!)

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] SDL makes me crazy (AARHHRG!!)
From: Ralf Kaestner <Ralf.Kaestner@xxxxxx>
Date: Tue, 04 Dec 2007 01:43:33 +0100
Cc: Roger Koot <r.h.h.koot@xxxxxxxxxxxxx>
Delivery-date: Mon, 03 Dec 2007 16:44:17 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Organization: http://freemail.web.de/
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Roger Koot wrote:

> have you tried to forget about the not-supported-yet intel driver and 
> opted for vesa as X driver? so no framebuffer. X won't be very 

very good idea! Had to try this immediately ...

Apart from the fact that the xorg vesa driver made my screen looking like if 
Magneto was directly sitting behind my Laptop hiding from the X-men (I suspect 
the sync values were screwed up somehow) - it did not work either :( - Same 
error in the qemu log.

And I tried xen 3.1.2 as well.

So finally I've put that stuff into /dev/vg0/lvTryAgainLater
Micheal Marineau told me he will have a new gentoo xen kernel probably based on 
2.6.21 available later in December - so I count on that.
Anyhow - if someone has another idea or even got a 965GM chipset working with 
SDL - please let me know.


is it normal that you can't disable and re-set mtrr's in Dom0 (e.g. echo 
"disable=6" >|/proc/mtrr)?
I just get something like "invalid argument" - but the same thing works fine 
without xen.

Jetzt neu! Schützen Sie Ihren PC mit McAfee und WEB.DE. 3 Monate
kostenlos testen. http://www.pc-sicherheit.web.de/startseite/?mc=022220

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>