This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] SDL makes me crazy (AARHHRG!!)

To: Xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] SDL makes me crazy (AARHHRG!!)
From: Ralf Kaestner <Ralf.Kaestner@xxxxxx>
Date: Mon, 03 Dec 2007 17:51:08 +0100
Delivery-date: Mon, 03 Dec 2007 08:51:53 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Organization: http://freemail.web.de/
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Hi all,

I am now trying since days to get SDL working for my Windows HVM. I think the 
problem I have is that I have no framebuffer device /dev/fb0 in Dom0 but I'm 
not sure.
Is that required for SDL to work? My expectation is - call xm create from out 
of an x-session running on top of Dom0 and wait for a window appearing on my 
x-screen :0.0 with the HVM DomU inside booting ... *dream ... dream on*

What I did:
- installed gentoo 2007 + xen-sources-2.6.20-r6 kernel.
- configured the kernel for Dom0 manually (I assume I dont need frontend 
virtual vesa for this? Tried anyhow with and without ...)
- at the beginning X wont work with my Laptop (intel 965GM graphics) on DOm0 
since the chipset was not supported yet in 2.6.20 - so I applied 
- finally X does start now on my Dom0 with "intel" as xorg device driver and I 
get a ugly basic XConsole + twm @ 1680x1050 24 bits via 915resolution on my 
Laptop Display

Anyhow, when I run "xm create -f /root/winxp" it does not want to start.
The qemu-dm log reports: "could not initialize SDL"

This is not really telling me anything so I modified ioemu's  sdl.c to report 
the SDL_GetError() and it is: "No available video device".
Ok, but my X-Server is running with the intel driver so why the helldoes it not 
find a video device?! 

So I thought maybe it needs an /dev/fb0 which I do not have in my Dom0.
First test "hwinfo --framebuffer" looks quite fine - so why the hell is there 
no fb0 device?

I have no UDEV issue - I triple checked. manual mknod does not help either.
When I just reboot into a non xen 2.6.22 gentoo kernel and use video=vesafb 
vga=0x31b it works well and I get an fb0 framebuffer device in /dev and a 
1280x1024 text console.

I tried:
- vesafb - does not even show up in dmesg
- vesafb-tng - does not work (I have 64bit - will try uvesafb later)
- intelfb - does  show up in dmesg but doesn't really load successfully - I 
modified the the source to teach it the pci id of my intel 965GM chipset GPU - 
looks better but still creates no /dev/fb0 - I didn't care since intelfb does 
not even work for my laptop with the latest gentoo kernel (unxenified)
- tried video=vesafb vga=0x31b xcons=xvc console=xvc0 console=tty1 as boot 
arguments for the dom0 kernel - no fb0 in DOM0

I would be able to provide log and config files but I am sure they are correct.

Maybe my basic understanding of the xen Dom0 console stuff is wrong. If I 
google around I would imagine console framebuffer in Dom0 should work as it 
does anywhere else.
So my last hope was that vesafb between 2.6.20 (the latest gentoo xen dom0 
kernel) and 2.6.22 the latest gentoo native kernel was changed somehow so that 
it does not work for my GPU in 2.6.20 but does work in 2.6.22 - but diff was 
very quiet. And also LKML or kernel org did not say anything about vesafb 

In a last attempt I was going to try to patch a 2.6.22 kernel with xen but the 
large amount of work let me stop right after I attempted one unsuccessful 

Anything that I've missed? I hope so since I am really new in "Linux as 
Desktop" so I am not really sure if my undestanding of sdl xorg and 
framebuffers is correct.
Or is my Hardware just too new for the xen dom0 kernel?
Der WEB.DE SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen!

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>