This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] problem in starting xend

To: "Nico Kadel-Garcia" <nkadel@xxxxxxxxx>
Subject: RE: [Xen-users] problem in starting xend
From: "Gautham Kampalapur Shankar, TLS, Chennai" <gauthamk@xxxxxx>
Date: Tue, 30 Oct 2007 12:48:17 +0530
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Tue, 30 Oct 2007 00:23:09 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <D309264CD3651841AA75658A610447580236818D@xxxxxxxxxxxxxxxxxxxxxx RP.HCL.IN> <4725BC08.1060402@xxxxxxxxx> <D309264CD3651841AA75658A610447580236818E@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx> <4725D2A5.9020101@xxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcgaJ3oUZiGcv80WS2WUXRs/dbeF6wAnZC3Y
Thread-topic: [Xen-users] problem in starting xend

-----Original Message-----
From: Nico Kadel-Garcia [mailto:nkadel@xxxxxxxxx]
Sent: Mon 10/29/2007 6:01 PM
To: Gautham Kampalapur Shankar, TLS, Chennai
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] problem in starting xend

Gautham Kampalapur Shankar, TLS, Chennai wrote:
> -----Original Message-----
> From: Nico Kadel-Garcia [mailto:nkadel@xxxxxxxxx]
> Sent: Mon 10/29/2007 4:25 PM
> To: Gautham Kampalapur Shankar, TLS, Chennai
> Cc: xen-users@xxxxxxxxxxxxxxxxxxx
> Subject: Re: [Xen-users] problem in starting xend
> Gautham Kampalapur Shankar, TLS, Chennai wrote:
> >
> > I tried to install xen, but got some errors when starting xend.
> >
> > as I logged in and tried to start xend
> > (/etc/init.d/xend start). I just got six-seven dot (.) printed out,
> > then it
> > stops. I looked more closely and found that xend could not start.
> >
> > then I looked at /var/log/xend-debug.log. here is the last few lines:
> >
> > ^^^
> >    Exception starting Xend: no element found: line 1 coloumn 0
> > ^^^
> > and i guess the problem is because of /etc/init.d/xend scripts in
> > await_daemons_up function or it may be failed because of other
> > reasons. anybody experienced this
> > problem, or know how to fix this?
> >
> > thanks gautham
> >
> How did you install Xen? What OS, and which version? Did you install and
> reboot with a Xen compatible kernel?
> i am using xen-3.1.0. and using it on linux-2.6.18 debian kernel.
> - untared the source, then "make world", then "make install".
> everything was fine
> - configure grub for xen
> - reboot the machine..
> as far as booting is concerned i have booted correct xen compatible kernel
> it was working fine for 2-3 days, i could run the  xend and boot the
> domU also.
> but once it has reported the problem of No Space Left error on the
> device... so i created some space for this purpose. after creating the
> space, i got this annoying error.
> Exception starting Xend: no element found: line 1 coloumn 0..
> final  message before this annoying message was
> Exception starting xend:(28, 'No Space left on device');
> i hope i am clear...
>So, you're using Debian, a locally compiled Xen, and a local file based
>Xen image installation.

>What does "df" say on your Dom0? Did you by chance generate a "sparce"
>file to put your Xen guest on?

the df output of the system are:

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda3             19299400  15981688   2337348  88% /
varrun                  478212        96    478116   1% /var/run
varlock                 478212         0    478212   0% /var/lock
udev                    478212        52    478160   1% /dev
devshm                  478212         0    478212   0% /dev/shm

i think the memory is sufficient, to handle xend request.

now the other info which i got from the xend.log file are:

[2007-10-30 11:52:27 4340] INFO (__init__:1094) Xend Daemon started
[2007-10-30 11:52:27 4340] INFO (__init__:1094) Xend changeset: unavailable.
[2007-10-30 11:52:27 4340] INFO (__init__:1094) Xend version: Unknown.
[2007-10-30 11:52:27 4340] ERROR (__init__:1094) Exception starting xend (no element found: line 1, column 0)
Traceback (most recent call last):
  File "/opt/final/smartnic/xen-3.1.0-src/dist/install/usr/lib/python/xen/xend/server/SrvDaemon.py", line 345, in run
    servers = SrvServer.create()
  File "/opt/final/smartnic/xen-3.1.0-src/dist/install/usr/lib/python/xen/xend/server/SrvServer.py", line 254, in create
    root.putChild('xend', SrvRoot())
  File "/opt/final/smartnic/xen-3.1.0-src/dist/install/usr/lib/python/xen/xend/server/SrvRoot.py", line 40, in __init__
  File "/opt/final/smartnic/xen-3.1.0-src/dist/install/usr/lib/python/xen/web/SrvDir.py", line 82, in get
    val = val.getobj()
  File "/opt/final/smartnic/xen-3.1.0-src/dist/install/usr/lib/python/xen/web/SrvDir.py", line 52, in getobj
    self.obj = klassobj()
  File "/opt/final/smartnic/xen-3.1.0-src/dist/install/usr/lib/python/xen/xend/server/SrvNode.py", line 30, in __init__
    self.xn = XendNode.instance()
  File "/opt/final/smartnic/xen-3.1.0-src/dist/install/usr/lib/python/xen/xend/XendNode.py", line 658, in instance
    inst = XendNode()
  File "/opt/final/smartnic/xen-3.1.0-src/dist/install/usr/lib/python/xen/xend/XendNode.py", line 60, in __init__
    saved_host = self.state_store.load_state('host')
  File "/opt/final/smartnic/xen-3.1.0-src/dist/install/usr/lib/python/xen/xend/XendStateStore.py", line 104, in load_state
    dom = minidom.parse(xml_path)
  File "xml/dom/minidom.py", line 1913, in parse
  File "xml/dom/expatbuilder.py", line 924, in parse
  File "xml/dom/expatbuilder.py", line 211, in parseFile
ExpatError: no element found: line 1, column 0
[2007-10-30 11:52:27 4339] INFO (__init__:1094) Xend exited with status 1.

i have look into much of python code but not getting clue about the error.




The contents of this e-mail and any attachment(s) are confidential and intended 
for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. 
Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the 
opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, 
distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is 
strictly prohibited. If you have 
received this email in error please delete it and notify the sender 
immediately. Before opening any mail and 
attachments please check them for viruses and defect.

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>