This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Boot error with 2.6.23 domU

To: Tomasz Chmielewski <mangoo@xxxxxxxx>
Subject: Re: [Xen-users] Boot error with 2.6.23 domU
From: Michael Heyse <mhk@xxxxxxxxxxxxxxxxx>
Date: Mon, 15 Oct 2007 21:17:58 +0200
Cc: Mark Williamson <mark.williamson@xxxxxxxxxxxx>, xen-users@xxxxxxxxxxxxxxxxxxx, Zoltan HERPAI <wigyori@xxxxxxx>
Delivery-date: Mon, 15 Oct 2007 12:18:48 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <470E3984.9040004@xxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <470DF0FB.6070506@xxxxxxxx> <200710111549.58913.mark.williamson@xxxxxxxxxxxx> <470E3984.9040004@xxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (Macintosh/20070728)
Tomasz Chmielewski schrieb:
> I tried vmlinux, but also, it didn't work.
> It hanged at:
> # xm create -c somedomain
> Using config file "/etc/xen/somedomain".
> Started domain somedomain
> And it seems to wait there forever.
> Normally, I would expect:
> # xm create -c somedomain
> Using config file "/etc/xen/somedomain".
> Started domain somedomain
>  Linux version 2.6.18-xen (root@....

Same thing here, nothing happens. Usually you should at least hear the
hard drive working even if there wouldn't be any console output.
2.6.20-xen (from gentoo) is working just fine.

Basic system configuration:

- VIA C3-2 CPU (Nehemia)
- Xen 3.1.0
- dom0 kernel: 2.6.20-xen (from gentoo)
- domU kernel: I tried both 2.6.23 vanilla and 2.6.23-gentoo, with and
  without SMP support.
- domU kernel .config: http://www.boppstrasse.de/config-2.6.23-gentoo

`xm list` shows that the domU's CPU time doesn't increase if I compile
it without local apic support, it's stuck somewhere between 0.6 and 1.0
seconds. When I enable local apic, the CPU time does increase steadily.
`xm dmesg` shows nothing when I boot the domU kernel.

Can anybody send me a known to be working 2.6.23 kernel .config so I can
try if it works on my system?


Xen-users mailing list