This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Boot error with 2.6.23 domU

To: Mark Williamson <mark.williamson@xxxxxxxxxxxx>
Subject: Re: [Xen-users] Boot error with 2.6.23 domU
From: Tomasz Chmielewski <mangoo@xxxxxxxx>
Date: Thu, 11 Oct 2007 16:56:04 +0200
Cc: xen-users@xxxxxxxxxxxxxxxxxxx, Zoltan HERPAI <wigyori@xxxxxxx>
Delivery-date: Thu, 11 Oct 2007 07:56:58 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <200710111549.58913.mark.williamson@xxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <470DF0FB.6070506@xxxxxxxx> <200710111549.58913.mark.williamson@xxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20061110 Mandriva/ (2007.1) Thunderbird/ Mnenhy/
Mark Williamson schrieb:
I compiled a 2.6.23 kernel with domU support, but the following error
shows up when I try to boot it on a Xen-3.1.0:

Error: (2, 'Invalid kernel', 'xc_dom_find_loader: no loader found\n')
Yep, same here.

Is there a fine manual somewhere on how to boot a 2.6.23 domU with Xen

Good to see that people are trying out the new Xen support in mainline!

To boot under Xen you need to use a vmlinux / vmlinuz image. Were you guys perhaps trying to use the bzImage? That won't work (yet).

The vmlinux that's in the root of your kernel build tree ought to work. I stripped and gziped mine to get a much, much smaller vmlinuz file and used it to boot a Xen domain for the first time last night - worked fine.

I tried vmlinux, but also, it didn't work.

It hanged at:

# xm create -c somedomain
Using config file "/etc/xen/somedomain".
Started domain somedomain

And it seems to wait there forever.

Normally, I would expect:

# xm create -c somedomain
Using config file "/etc/xen/somedomain".
Started domain somedomain
 Linux version 2.6.18-xen (root@....

Tomasz Chmielewski

Xen-users mailing list