This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Xen 3.1 amd64 - Debian 386

To: xen-users@xxxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Xen 3.1 amd64 - Debian 386
From: Raz <raz@xxxxxxxxxxxxx>
Date: Thu, 04 Oct 2007 13:05:41 +0200
Delivery-date: Thu, 04 Oct 2007 04:06:45 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (Windows/20070728)
Hi - hoping someone can help with this. I'm relatively new to Xen but do have a working VM. It's a simple config which I created using xen-create-image. The system I'm using is a single CPU Opteron (model 1214) & 4GB RAM running Debian (lenny) with the Debian etch xen packages and from what I can tell all seems to work fine.

The problem comes in when I try to create a Debian 386 VM on 64-bit Xen system - although I modified the example cfg file that was part of the xen-utils-common package (xmexample.hvm), as a template, I'm having no luck - see below. I'm still not too clear on the different models that Xen supports so I could be wrong on my approach.

Once I have solved this I'll attempt a WinXP VM :-)

thanks Raz.

# xm create xen-ethc-i386.cfg

[2007-10-03 14:21:04 3297] DEBUG (__init__:1072) Waiting for devices vtpm.
[2007-10-03 14:21:04 3297] INFO (__init__:1072) Domain etch-386 (3) unpaused. [2007-10-03 14:21:04 3297] INFO (__init__:1072) Domain has shutdown: name=etch-386 id=3 reason=poweroff. [2007-10-03 14:21:04 3297] DEBUG (__init__:1072) XendDomainInfo.destroy: domid=3 [2007-10-03 14:21:04 3297] DEBUG (__init__:1072) XendDomainInfo.destroyDomain(3)

domid: 3
qemu: the number of cpus is 1
Watching /local/domain/3/logdirty/next-active
qemu_map_cache_init nr_buckets = 10000
shared page at pfn 1ffff
buffered io page at pfn 1fffd
Time offset set 0
I/O request not ready: 0, ptr: 0, port: 0, data: 0, count: 0, size: 0
Triggered log-dirty buffer switch

### xen-etch-i386.cfg
kernel = "/usr/lib/xen-3.1-1/boot/hvmloader"
memory = 512
name = "etch-386"
vif = [ 'type=ioemu, bridge=xenbr0' ]
disk        = [
'file:/home/vm/domains/xen-etch-i386/xen-etch-i386.disk.img,sda1,w', 'file:/home/vm/domains/xen-etch-i386/xen-etch-i386.swap.img,sda2,w',
device_model = '/usr/lib/xen-3.1-1/bin/qemu-dm'

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>