This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] mount: could not find filesystem '/dev/root'

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] mount: could not find filesystem '/dev/root'
From: "Ismael Hasan Romero" <kraziest@xxxxxxxxx>
Date: Sun, 8 Apr 2007 02:12:14 +0200
Delivery-date: Sat, 07 Apr 2007 17:11:11 -0700
Dkim-signature: a=rsa-sha1; c=relaxed/relaxed; d=gmail.com; s=beta; h=domainkey-signature:received:received:message-id:date:from:to:subject:mime-version:content-type:content-transfer-encoding:content-disposition; b=tXHnQ9/O9jbBjXlCLMvrgiyDQF8SlAOmYQSUr/AUAO0L9m22cNsQu1W11RgpiT9Ygz5La7C9ytwoS7bY/3trIh/h23vbc4+ovUmoS4V8XDOYQKUo5XrwXA1MyHjRPaQEdHARttOE0I+SqbcPNx/ILgSlFj7VQtav9yaSn61a/d4=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:mime-version:content-type:content-transfer-encoding:content-disposition; b=NIgntsj4oUvAbOL3cKyg9IPs47Otx6y/TdI5l7I7uN2zeUMIkChxBaD+TNZHTTdmBKoauCoOB8IqupYvVKeD9u7izGY2iehjaG5/hPJ9dav2/4d8lFlED8hse2NrRviMpm4QibE5KwSjlSVkjuxEPUVjECK2Rb4rjBXg3YcxXYk=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Hi there. I got a kernel panic caused by <mount: could not find
filesystem '/dev/root'> when I tried to install xen from the sources
(to compile modules on my own).

Now I have installed in my system Fedora Core 5 the following kernels:

2.6.20-1 xen0
2.6.16 xen
2.6.18-1 xen0

All of the kernels run ok except the 2.6.16 xen kernel, it causes the
kernel panic on boot. I downloaded this from the repositories in
http://xenbits.xensource.com/, the xen-3.0.3-testing.hg; I used
mercurial to get a copy.

I followed the Readme so I did

make world
make install

Then I had in my /boot what we ned to boot except the initrd. I made
it twice and none of them worked:

-mkinitrd -v -f --with=aacraid --with=sd_mod --with=scsi_mod
initrd-      -> that's the Readme way
-mkinitrd initrd-       -> when the
Readme didn't work

I have no idea what the problem can be, if something similar occured
to anyone or anyone can give me a light about this problem it would be
a great help.

If someone needs more details about my configuration or else just ask me please.

One last thing, before the kernel panic occurs a warning appears. This
is about "unsupported acesses", it sais that there is a problem with
the /lib/tls and that because of this the system may run slow. If
someone believe that this is important I can copy here the exact

Xen-users mailing list