This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] nfsroot domU issues

To: <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] nfsroot domU issues
From: "Marlier, Ian" <ian.marlier@xxxxxxxxxxxxxxxxxxx>
Date: Thu, 21 Sep 2006 11:12:33 -0400
Delivery-date: Thu, 21 Sep 2006 08:13:31 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcbdkF1GtyuDp11JQ06IjbDBgy0RrQ==
Thread-topic: nfsroot domU issues
Hi, all --

I'm hoping that I might be able to gain some clarity here on xen
machines using an NFS-root filesystem (and what's going on with my
attempts to make them work).

Dom0 and DomU are both running SUSE Linux 10.1.  Version info:
offxen0:~ # rpm -qa | grep xen-3
offxen0:~ # uname -a
Linux offxen0 #1 SMP Tue Aug 29 16:42:05 UTC 2006
i686 athlon i386 GNU/Linux
offxen0:~ #
I installed the OS to a local partition, and that works fine.  I rebuilt
the initrd with the xennet and nfs modules included, and that still
works fine (those modules are loaded within the initrd).

I then copied the working machine over to an NFS share, leaving a copy
of the initrd and the kernel on the host, as /tmp/initrd-xen-nfs and

However, when I attempt to start the machine, I get the following:
offxen0:~ # xm create -c /etc/xen/vm/local
Using config file "/etc/xen/vm/local".
Started domain local
Linux version (geeko@buildhost) (gcc version 4.1.0
(SUSE Linux)) #1 SMP Tue Aug 29 16:42:05 UTC 2006
0MB HIGHMEM available.
264MB LOWMEM available.
ACPI in unprivileged domain disabled
Built 1 zonelists
Kernel command line:
nfsroot=,nfsvers=3  TERM=xterm
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
NET: Registered protocol family 2
IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
TCP established hash table entries: 16384 (order: 5, 131072 bytes)
TCP bind hash table entries: 16384 (order: 5, 131072 bytes)
TCP: Hash tables configured (established 16384 bind 16384)
TCP reno registered
NET: Registered protocol family 1
Using IPI No-Shortcut mode
XENBUS: Timeout connecting to devices!
Freeing unused kernel memory: 172k freed
Starting udevd
Creating devices
Loading xennet
netfront: Initialising virtual ethernet driver.
Loading xenblk
Loading xennet
Registering block device major 3
Loading jbd
Loading ext3
Loading nfs_acl
Loading lockd
Loading nfs
Mounting root
mount server reported tcp not available, falling back to udp
mount: RPC: Remote system error - Network is unreachable
umount: /dev: device is busy
umount: /dev: device is busy
Kernel panic - not syncing: Attempted to kill init!

The domU configuration that I'm using is this:
offxen0:~ # cat /etc/xen/vm/local
disk = [ 'phy:/dev/xenmachines/local-swap,hda1,w' ]
memory = 256
vcpus = 1
builder = 'linux'
name = 'local'
vif = [ 'mac=00:16:3e:57:3e:e4, bridge=xenbr0' ]
localtime = 0
ip = ''
netmask = ''
gateway = ''
hostname = 'local'
root = '/dev/nfs'
nfs_server = ''
nfs_root = '/space/XenMachines/master-32'
on_poweroff = 'destroy'
on_reboot = 'restart'
on_crash = 'restart'
extra = ' TERM=xterm'
kernel = '/tmp/vmlinuz-xen-nfs'
ramdisk = '/tmp/initrd-xen-nfs'
#bootloader = '/usr/lib/xen/boot/domUloader.py'
#bootentry = 'hda2:/boot/vmlinuz-xen'

In googling around, I've found references to two resolutions, on this
list and elsewhere:
- Switch to routed network, from bridged.  I've tried swapping the
network-script and vif-script variables to 'network-route' and
'vif-route' (respectively), but that doesn't seem to have done much of
anything -- the behavior is identical.

- "Create the bridge in your initramfs" (from
tml).  Which sounds like an interesting idea, but I have to admit that I
barely know what it means, and really don't know how to implement it
:-)...Can anyone enlighten me?

Alternately, is there anything that I'm just straight missing?

I tried `man 5 xmdomain.cfg`, but ran into this:
       NFS Root
           FIXME: write me
which isn't helping much...

Thanks in advance for ANY help...I'm going to go get some ice for my
forehead...it hurts from banging into this wall... :-)

- Ian

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] nfsroot domU issues, Marlier, Ian <=