This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Creating telnet access to console

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Creating telnet access to console
From: Jaap Krabbendam <jkrabbendam@xxxxxxxxx>
Date: Thu, 21 Sep 2006 16:21:17 +0200
Delivery-date: Thu, 21 Sep 2006 07:22:12 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <45126509.4020100@xxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <450E955D.5090902@xxxxxxxxxxx> <45126509.4020100@xxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla Thunderbird 1.0.7-1.1.fc3 (X11/20050929)

service xen_vpn_test
        disable         = no
        type            = UNLISTED
        socket_type     = stream
        protocol        = tcp
        user            = root
        wait            = no
        port            = 9001
        server          = /usr/sbin/xm
        server_args     = console vf-VPN-TEST

I'm unable to login to the domain, the telnet connection is closed directly without any output.


I tried the same as you and it works for me. I use a FC5 xen0/xenU
(uname -r => 2.6.17-1.2174_FC5xen0). This is what I did:
o Add a file with name xen (this name is unimportant) to /etc/xinetd.d
with the contents as you published. I only changed the domU system name.
o killall -HUP xinetd
o telnet localhost 9001   #This worked. I had to hit CR a couple of
times though.
o telnet on a remote machine also worked.

Maybe ..
o you can check whether port 9001 in dom0 is taken by an other process.
o try first with localhost
o check with  ethereal if some messages are exchanged.
o check with top/ps if you see the xm executable launched

Good luck.
Jaap Krabbendam.

This message has been scanned for viruses and is believed to be clean

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>