This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Xen 3.0.2-2 + linux-2.6-xen-fedora

Am Dienstag, den 19.09.2006, 23:43 +0800 schrieb Adrian Chadd:
> On Tue, Sep 19, 2006, Christophe Saout wrote:
> > XEN-Hypervisor and XEN-Tools from the xen-unstable tarballs (from about
> > the same date, 0815 and 0915). While it all usually worked well, I've
> > seem some strange things sometimes.
> > 
> > After a domain crash or some manual destroys, xm suddenly told me
> > "Domain 0 not connected". After a restart of xend, "xm list" worked
> > again, but any further "xm create" would fail with "hotplug not
> > working" (for the vif device). I also had some undestroyed vif devices
> > from destroyed domains dangling around.
> > 
> > I don't see how hotplug (or udev to be precicse) should suddenly fail.
> > And what is "Domain 0 not connected" about? It seems like something
> > suddenly forgot its state and really got confused. The vif devices
> > should have been destroyed by xend and not hotplug, right?
> > 
> > The only way to "fix" the problem was to reboot the machine. Has anybody
> > else seen something like that?
> Yeah - my 2.6.17 paravirt kernels from FC5 will crash (and I didn't get
> a stack trace when this happened, but I will next time!) and they'll
> actually take the networking for all other xen's down with them.

That's exactly what happened the first time. I don't know why. After
three weeks without problems this suddenly happened on two different
physical machines almost at the same time and once again four hours
later. I then upgraded to the 2.6.18-rc6 patch and newest hypervisor and
tools, hoping that this was a bug and had been fixed. While I didn't
observe it crashing by itself (well, I updated just two days ago), I saw
the phenomenon again after having destroyed all guest domains manually.

> xm shutdown will successfully shut the domU environment down but it'll
> zombie the kernel instead of cleanly destroying the domain.
> I have to reboot to recover. restarting xend doesn't do anything
> (and I haven't checked the logs to see what it failed to do, save
> being unable to destroy domains..)

I haven't seen anything suspicious in the logs either. Just that a
domain had crashed, xend having trouble restarting it until it decided
to abort, and then other domains suddenly crashing as well or staying
around as zombies without network connection (still accessible via

> Its a bit weird that a domU crashing can take out everything else.
> I'd hate to find someone reliably replicating it and using it as a
> DoS.. :/

Do you know if this problem is known?  Is there a Bugzilla bug
somewhere? Is it specific to post-2.6.16.x ports?

Attachment: signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil

Xen-users mailing list