This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Xen 3.0.2-2 + linux-2.6-xen-fedora

Am Dienstag, den 19.09.2006, 12:21 -0300 schrieb James Oakley:

> I'm running SUSE's 2.6.18_rc6_git3 and xen-3.0.3_11440-3 just fine. LVM and 
> HVM are working.

I've been running 2.6.18-rc3 and -rc6 with the Fedora patch and the
XEN-Hypervisor and XEN-Tools from the xen-unstable tarballs (from about
the same date, 0815 and 0915). While it all usually worked well, I've
seem some strange things sometimes.

After a domain crash or some manual destroys, xm suddenly told me
"Domain 0 not connected". After a restart of xend, "xm list" worked
again, but any further "xm create" would fail with "hotplug not
working" (for the vif device). I also had some undestroyed vif devices
from destroyed domains dangling around.

I don't see how hotplug (or udev to be precicse) should suddenly fail.
And what is "Domain 0 not connected" about? It seems like something
suddenly forgot its state and really got confused. The vif devices
should have been destroyed by xend and not hotplug, right?

The only way to "fix" the problem was to reboot the machine. Has anybody
else seen something like that?

Attachment: signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil

Xen-users mailing list