This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] DomU install using Yast2 xen can't find CDROM installati

To: "Matthew Wild" <M.Wild@xxxxxxxx>
Subject: Re: [Xen-users] DomU install using Yast2 xen can't find CDROM installation source (HDIO_GET_IDENTITY failed)
From: XenResu <xenresu@xxxxxxxxx>
Date: Mon, 11 Sep 2006 10:42:59 -0400
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Mon, 11 Sep 2006 07:43:49 -0700
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:sender:to:subject:cc:in-reply-to:mime-version:content-type:references:x-google-sender-auth; b=dsdVC3n/G/OzgQSSLEi6YYxzQ4lt8+MGgCgxx5G5BOADhEOZoSqYXb6XX5wKBWN28KxKLlZo4aU3v73MS9UmB4FnHThGWHV/NkN4OedH+ViNjzlGmY2acf3VRmyJxpuCrO8VwxQLo7UO+pJXwAOMXJBzQKE9rSeRksoOTItxYB0=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <200609080928.56488.M.Wild@xxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <8ff8d19d0608311100y3d76342clf102028951174e9@xxxxxxxxxxxxxx> <8ff8d19d0609071336x58006696ne5228732ed49dfef@xxxxxxxxxxxxxx> <4500F8BD.9000906@xxxxxxxxxxxxxxx> <200609080928.56488.M.Wild@xxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Some success, finally!
dom0 - SLES10
domU - OpenSuSE (SLES installation source) install via DVD ISO or DVD CDROM
The init/linuxrc script would run but complain that it couldn't find the installation source (the installation source mapped to hdb in the configuration file)
I jumped through hoops detaching-attaching the block device, seeing the 'can't find installation source' message every time.
This worked for me:
When linuxrc fails with "Could not find the SUSE Linux Installation Source.  Activating manual setup program."
  • press <enter> to acknowledge the OK button
  • select the language
  • choose a keyboard map
  • start installation or system
  • start installation or update
  • choose the source medium -> hard disk
  • (optional) configure vnc
  • enter the hard disk partition -> hdb (the installation source)
  • enter the source directory -> (leave blank)
Installation continues...
Thanks for all the help.
On 9/8/06, Matthew Wild <M.Wild@xxxxxxxx> wrote:
On Friday 08 September 2006 05:59, Noniko wrote:
> Hi
> > SLES 10, same error.  I must admit Xen is one of the least usable
> > products I've come across in quite a while.
> Mmmmm....
> Is the problem only on CD usage?
> Has your Xen env succeeded in the classical way of making image file
> manually?
I've been using SuSE 10.1 quite happily to run Xen. I use yast2 dirinstall
from the xen server on the 'disk' assigned for the virtual machine. Then a
few tweaks to the /etc/fstab and /etc/inittab files and I can create the
virtual machine.

One gotcha is that you need to disable any update installation sources on the
xen server as the zen update stuff gets in a mangle and won't release the
mounted disk for ages. I think it's getting confused over what needs updating
on the server and the dirinstall area. Just run the update from within the
virtual machine after you've got networking set up.

Matthew Wild                       Tel.: +44 (0)1235 445173
M.Wild@xxxxxxxx                    URL http://www.ukssdc.ac.uk/
UK Solar System Data Centre and
World Data Centre - Solar-Terrestrial Physics, Chilton
Rutherford Appleton Laboratory, Chilton, Didcot, Oxon, OX11 0QX

Xen-users mailing list

Xen-users mailing list