This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] pvops Domain 0 Creased when boot Xen-unstable on Ubuntu1

To: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Subject: Re: [Xen-devel] pvops Domain 0 Creased when boot Xen-unstable on Ubuntu10.04
From: Bei Guan <gbtju85@xxxxxxxxx>
Date: Tue, 17 May 2011 23:27:34 +0800
Cc: Xen Devel <xen-devel@xxxxxxxxxxxxxxxxxxx>, Andrei Warkentin <andreiw@xxxxxxxxxxxx>
Delivery-date: Tue, 17 May 2011 08:29:14 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:in-reply-to:references:date :message-id:subject:from:to:cc:content-type; bh=zw8XlBPj0Dng/v0A1NH7tUWiTkeHSRX/7ceCODF3YhM=; b=bTsJlbp8Ou3WHKN0xaEsDfVMS6BEXmS3ES8L7fn3CPaxvDh2mUsAiiCKi7eXHcjKQr CD1LkBUFgZcuromzFa9R3/D44rvMwUU67CNqQaFg1LnmjNL13jNcr8JO4hlkf74qY8rV tMuXf7wfxnY6Bu8ldWBAgzegfRm+2pCZQwOus=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type; b=C6GhFMwX0TpySAwxdKDwiQG6BIuhDC8TRjd8A/nSC31scKzh5sTWjeffShN1JKyeE8 AeMWtLpSHe1ubajeQpC4nMqPJ5ngpwHheOUfgyz9Kz4c3Gb3QYi87OxWah/8i00zCF/P 9lHyNh46PfxcvyTpKGVCw8L3iAACMWgwVmBVc=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20110517144421.GA7597@xxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <BANLkTimALuDSgaw_UeuC4vf+Vyfd7+Sufg@xxxxxxxxxxxxxx> <20110516175320.GA5722@xxxxxxxxxxxx> <BANLkTi=sQ0TCSG7ky2pj3QB=Heq-biuERw@xxxxxxxxxxxxxx> <20110517144421.GA7597@xxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx

2011/5/17 Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
> menuentry "Ubuntu_Xen 4.2 (" {
> recordfail
> insmod ext2
> set root='(hd0,9)'
> search --no-floppy --fs-uuid --set 59c64afa-47a8-4a5f-a4cf-dbe3be20cc15
>         multiboot /boot/xen.gz dom0_mem=1024M loglvl=all guest_loglvl=all
> sync_console console_to_ring com1=115200,8n1 console=com1 lapic=debug
> apic_verbosity=debug apic=debug iommu=off
> module /boot/vmlinuz- nopat
> root=UUID=59c64afa-47a8-4a5f-a4cf-dbe3be20cc15 ro console=tty0
> console=ttyS0,115200n8 console=hvc0 earlyprintk=xen nomodeset initcall_debug
> debug loglevel=10
> module /boot/initrd.img-
> }
> In the debug, there is message like this:
> Loading, please wait...
> mount: mounting none on /dev failed: No such device

So your /dev/sda is being seen. Not sure why the UUID hasn't been read, but
you could do 'root=/dev/sdaX' where X is the correct root partition.

This would replace the 'UUID=59...'.
I just tried this. Because the /dev/sda9 is the root fs, so I used 'root=/dev/sda9' to replace the original one. But it also the same error as the following. Detailed is also attached.

Loading, please wait...
mount: mounting none on /dev failed: No such device

The fs in my pc.
root@gavinguan-desktop:~# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda9              31G   14G   16G  47% /
none                  1.9G  288K  1.9G   1% /dev
none                  1.9G   24K  1.9G   1% /dev/shm
none                  1.9G   92K  1.9G   1% /var/run
none                  1.9G     0  1.9G   0% /var/lock
none                  1.9G     0  1.9G   0% /lib/init/rw

Bei Guan

Attachment: boot_log_2.txt
Description: Text document

Xen-devel mailing list