This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Bug in PCI Passthrough

To: Josef Vogt <josef.vogt@xxxxxxxxxx>
Subject: Re: [Xen-devel] Bug in PCI Passthrough
From: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Date: Wed, 20 Apr 2011 08:51:56 -0400
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Wed, 20 Apr 2011 05:54:56 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4DAEA42B.3010600@xxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <4DAEA42B.3010600@xxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.20 (2009-06-14)
On Wed, Apr 20, 2011 at 11:15:23AM +0200, Josef Vogt wrote:
> Hello all
> I tried to enable PCI Passthrough in my Debian Squeeze installation.
> Unfortunately, it didnt work. The following bug showed up (excerpt
> from dmesg):
> [ 10.148612] uhci_hcd 0000:00:14.2: PCI INT D -> Link[LNKD] -> GSI 11
> (level, low) -> IRQ 11
> [ 4.678352] Failed to setup GSI :11, err_code:-22
> [ 4.678480] dmfe 0000:00:0e.0: PCI INT A -> Link[LNKB] -> GSI 11 (level,
> low) -> IRQ 11
> [ 6.868419] Failed to setup GSI :10, err_code:-22

That is most strange. Your interrupts are below IRQ 16, and they are level?
They should have been edge, unless you have some strange machine.

If you don't pass in the card to the DomU, but run it under Dom0, what is
the GSI and /proc/interrupts for the dmfe?

Can you also attach the full serial output? (so we can see the Xen hypervisor 
and the Linux Dom0 output).
> Strange thing is, it worked perfectly with Debian Lenny Kernel 2.6.26 [1]

Way different implementation of the interrupt stack.

Xen-devel mailing list