This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Bug in PCI Passthrough

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] Bug in PCI Passthrough
From: Josef Vogt <josef.vogt@xxxxxxxxxx>
Date: Wed, 20 Apr 2011 11:15:23 +0200
Delivery-date: Wed, 20 Apr 2011 02:16:24 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20110307 Icedove/3.0.11
Hello all

I tried to enable PCI Passthrough in my Debian Squeeze installation. Unfortunately, it didnt work. The following bug showed up (excerpt from dmesg):

[ 10.148612] uhci_hcd 0000:00:14.2: PCI INT D -> Link[LNKD] -> GSI 11
(level, low) -> IRQ 11
[ 4.678352] Failed to setup GSI :11, err_code:-22
[ 4.678480] dmfe 0000:00:0e.0: PCI INT A -> Link[LNKB] -> GSI 11 (level,
low) -> IRQ 11
[ 6.868419] Failed to setup GSI :10, err_code:-22

Strange thing is, it worked perfectly with Debian Lenny Kernel 2.6.26 [1]

I first thought, it was a Debian bug[2], but then I tried the vanilla kernel (xen/stable-2.6.32.x from kernel.org) the bug was exactly the same. See also [1] for the the exact error messages.
I also tried to get help from xen users list [3].
Strange side note: It seems to work with opensuse 11.2 (kernel 3.6.31) and also Opensuse 11.3 (kernel 3.6.34) – I installed them both but didnt get the above error message. The interrupts were assigned correctly. So i started looking at the code, but the used code in Opensuse looks quite different to the xen code in kernel.org. (I didn't find xen.c, where the error message „Failed to setup GSI“ is located). Is it possible that Opensuse uses Xen source code from an older branch? I also compiled xen/next-2.6.39 (up to this commit: 6f3ba85fbef08ce0d833a1943827454b3e5532b7) but then, unfortunately the dom0 crashes.

All the above together (except the dom0 crash in 2.6.39, of course) let's me think, this could a bug in xen kernel source code.

[1] http://lists.xensource.com/archives/html/xen-users/2011-01/msg00411.html
[2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=610832
[3] http://lists.xensource.com/archives/html/xen-users/2011-01/msg00388.html

Xen-devel mailing list