This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] RE: Windows7 Home, PV drivers (x32_0.11.0.238) stuck dur

To: James Harper <james.harper@xxxxxxxxxxxxxxxx>
Subject: Re: [Xen-devel] RE: Windows7 Home, PV drivers (x32_0.11.0.238) stuck during install (image attached)
From: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Date: Tue, 8 Mar 2011 20:27:15 -0500
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Tue, 08 Mar 2011 17:28:23 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20110309010405.GA10665@xxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20110308185316.GA3396@xxxxxxxxxxxx> <AEC6C66638C05B468B556EA548C1A77D01C55D4D@trantor> <20110309010405.GA10665@xxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.20 (2009-06-14)
> > When it is hung like that, can you go into device manager and tell me
> > what xen devices are loaded?
> Nothing shows up as Xen. I ran Lavasys Everest to do a report and scanned
> for anything that said 'Xen'. The only things I found were the DMI fields.
> Interestingly enough, if I click "Cancel" it is still hung. Are there
> any installation logs of what it tried to load/install?

It does Cancel, just takes a bit of time. Found out that running
the installer with /l* Logfile.txt did the trick and saw this:

.. snip..
DIFXAPP: INFO:   No matching devices found in INF 
 on the Machine.
DIFXAPP: INFO:   No drivers installed. No devices found that match driver(s) 
contained in 
DIFXAPP: INFO:   RETURN: DriverPackageInstallW  (0xE000020B)
DIFXAPP: INFO: The device(s) for which the driver is being installed has not 
been plugged into the computer.
DIFXAPP: INFO:   ENTER:  DriverPackageGetPathW
DIFXAPP: INFO:   RETURN: DriverPackageGetPathW  (0x7A)
DIFXAPP: INFO:   ENTER:  DriverPackageGetPathW
DIFXAPP: INFO:   RETURN: DriverPackageGetPathW  (0x0)
DIFXAPP: INFO: driver store entry for 'C:\Program Files\Xen PV 
Drivers\drivers\xenpci\xenpci.inf' is 
DIFXAPP: INFO: The component Id '{D6BB9B5F-61F9-4B6E-8FAD-289706F5EBEB}' is now 
set to point to driver store: 
DIFXAPP: INFO: A reboot is not needed to install the component 
DIFXAPP: RETURN: InstallDriverPackages() 0 (0x0)
Action 1:11:12: WaitForDevices. 

And sure enough I did not have a Xen PCI platform device.
The reason being that I had this in my guest configuration file:

#   Enable/disable xen platform PCI device, default=1 (enabled)

Changing it to 1 made the installer work. After two reboots
my Windows 7 guest is running with the PV drivers.

Xen-devel mailing list