This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] RE: Windows7 Home, PV drivers (x32_0.11.0.238) stuck dur

To: James Harper <james.harper@xxxxxxxxxxxxxxxx>
Subject: Re: [Xen-devel] RE: Windows7 Home, PV drivers (x32_0.11.0.238) stuck during install (image attached)
From: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Date: Tue, 8 Mar 2011 20:04:05 -0500
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Tue, 08 Mar 2011 17:06:31 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <AEC6C66638C05B468B556EA548C1A77D01C55D4D@trantor>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20110308185316.GA3396@xxxxxxxxxxxx> <AEC6C66638C05B468B556EA548C1A77D01C55D4D@trantor>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.20 (2009-06-14)
On Wed, Mar 09, 2011 at 09:16:53AM +1100, James Harper wrote:
> > Hey James,
> > 
> > I just installed a Windows 7 Home Premium version under QEMU
> (xen-unstable)
> > with a 2.6.38 dom0. Installing and running it under QEMU works quite
> well.
> > 
> > I decided to install the PV drivers and followed the criteria for
> > allowing self-signed drivers to be installed:
> > 
> > Bcdedit.exe -set TESTSIGNING ON
> > 
> > And then I tried to install the non-debug and debug version of the
> > GPL drivers. The version I picked was - and it just sits
> > there doing nothing. The Windows 7 install is stock + Kaspersky
> AntiVirus 2011
> > +
> > Everest Ultimate. Both of them (non-debug and debug) hang at the same
> point.
> > 
> > Any ideas what I ought to try? Where are the log files for the install
> > located?
> I think I've seen this once before but couldn't reproduce it. The
> installer waits for all the devices to be ready before asking for a
> reboot, otherwise you'll end up with the 0x7B "boot device inaccessible"
> BSoD next boot.
> When it is hung like that, can you go into device manager and tell me
> what xen devices are loaded?

Nothing shows up as Xen. I ran Lavasys Everest to do a report and scanned
for anything that said 'Xen'. The only things I found were the DMI fields.

Interestingly enough, if I click "Cancel" it is still hung. Are there
any installation logs of what it tried to load/install?

Xen-devel mailing list