This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] 2.6.37 dom0 non-fatal BUG: sleeping function called from

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] 2.6.37 dom0 non-fatal BUG: sleeping function called from invalid context at kernel/mutex.c:85
From: Pasi Kärkkäinen <pasik@xxxxxx>
Date: Thu, 6 Jan 2011 21:35:40 +0200
Cc: Ian Campbell <Ian.Campbell@xxxxxxxxxx>, Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Delivery-date: Thu, 06 Jan 2011 11:36:29 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20110106182314.GO2754@xxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20110106173628.GL2754@xxxxxxxxxxx> <20110106182314.GO2754@xxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.18 (2008-05-17)
On Thu, Jan 06, 2011 at 08:23:14PM +0200, Pasi Kärkkäinen wrote:
> On Thu, Jan 06, 2011 at 07:36:28PM +0200, Pasi Kärkkäinen wrote:
> > Hello,
> > 
> > First of all.. big thanks to everyone involved in upstreaming Xen dom0 
> > bits! 
> > 
> > I just tried upstream pvops 2.6.37 dom0 kernel on one of my machines, and 
> > it worked
> > out-of-the-box ! Even nouveau kms/modesetting worked just fine.
> > 
> > There was non-fatal BUG/traceback though:
> > 
> > Full dmesg log available at: 
> > http://pasik.reaktio.net/xen/logs/dmesg-2.6.37-1.xendom0.fc15.x86_64-kms-modesetting.txt
> > 
> Additional data.. latest xen/stable-2.6.32.x dom0 kernel ( doesn't 
> have this BUG/traceback.

Sorry for the noise.. it seems this is a bug in the xhci driver in 2.6.37.
It's already fixed upstream but the fix is not in 2.6.37.

I noticed the bugreport from lkml, it seems to happen also on baremetal for 
other people.
(it didn't for me).

Well.. at least it was not xen dom0 specific bug :)

-- Pasi

From: Greg KH <gregkh@xxxxxxx>
To: Robert Hancock <hancockrwd@xxxxxxxxx>
Cc: Sarah Sharp <sarah.a.sharp@xxxxxxxxxxxxxxx>,
        Linux-usb <linux-usb@xxxxxxxxxxxxxxx>,
        linux-kernel <linux-kernel@xxxxxxxxxxxxxxx>
Date: Wed, 5 Jan 2011 16:30:03 -0800
Subject: Re: Sleeping function called from invalid context in 2.6.37 xhci_hcd

On Wed, Jan 05, 2011 at 06:22:03PM -0600, Robert Hancock wrote:
> Just saw this on booting up on the latest Fedora Rawhide kernel
> based on 2.6.37. Looks like we were trying to do a runtime suspend
> on the xHCI USB controller and it disabled MSI-X while interrupts
> were disabled?

Known issue, patches came in too late to make it for .37, hopefully will
show up in .38-rc and then get backported to .37.  They are on the
linux-usb mailing list if you need them now.

Hope this helps,

greg k-h

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>