This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Xen dom0 crash: "d0:v0: unhandled page fault (ec=0000)"

To: sven <ml@xxxxxxxxxxxxx>
Subject: Re: [Xen-devel] Xen dom0 crash: "d0:v0: unhandled page fault (ec=0000)"
From: Gianni Tedesco <gianni.tedesco@xxxxxxxxxx>
Date: Tue, 19 Oct 2010 16:45:43 +0100
Cc: "Alan J. Wylie" <NDA5OWUy@xxxxxxxxxxx>, Jeremy Fitzhardinge <jeremy@xxxxxxxx>, "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Tue, 19 Oct 2010 08:46:36 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4CBDB229.3030501@xxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <19629.39326.337589.71778@xxxxxxxxxxx> <1287498599.12843.2111.camel@xxxxxxxxxxxxxxxxxxxxxx> <4CBDB229.3030501@xxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
On Tue, 2010-10-19 at 15:58 +0100, sven wrote:
> Hello,
> I just wanted to report that I'm affected by this issue, too.
> (I subscribed to this list in the meantime; this is the first post I can 
> reply-to in context)
> As it seems to be a moving target and not being bound to a specific 
> config-option (As proven by Alan in previous posts as well as my 
> personal experience), I suspected the build-env and tried several 
> Distributions - Ubuntu 10.04/10, Debian Lenny and Fedora 13.
> Tried both an Athlon X2 and Intel i7.

ditto, I suspected a known bug in my gcc version which broke xchg
because when I compiled with -O2 instead of -Os... the problem went away
but then something else bad happened later (I forget the details, and it
was too many config tweaks ago to get back to last time I had it working
that well)

it's clearly one of those fun and subtle bugs :(


Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>