This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] pv-ops domU not working with MSI interrupts on Nehalem

To: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Subject: Re: [Xen-devel] pv-ops domU not working with MSI interrupts on Nehalem
From: Bruce Edge <bruce.edge@xxxxxxxxx>
Date: Fri, 1 Oct 2010 16:30:35 -0700
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 01 Oct 2010 16:31:38 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:received:in-reply-to :references:date:message-id:subject:from:to:cc:content-type :content-transfer-encoding; bh=KIJ/ICEbKey+jzjtx47ddfxNT89cT6lKfKDBinxNGeY=; b=RtRtKSRYjQOijPXbzOFKGtOpnFm0UV0hbTWrJlHO0M+f7kVsf9XHgo+rHVScZbW7qX w7y5CTstNWCzP5+qevPBvc1kwBpG3fxRU2wDSsDLb/n39e3S0wqPmByFZzJw3E8UtEyF dfyonAfg1GYGsNOxouLevNrG0HYFo7E6NvjOg=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=iFWh1cvDu8YHqag32NjVIa3zmDSrOduxqWz7X3u0K8x4cvq+P8fQdiQAjOAM66pU// VXuvEmhPD6wCv8r6pwUFlJV1g+YjT0DxO+/HGH9sxZI9cihx5tEwsaiia4KNqPBnE0AG OdohPzGg4tjbrasbYyghL2f+6WJ5SQCqkMlUM=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20101001211111.GA18244@xxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <AANLkTi=G7CTuVP2=b18JjwFsCb_fvk8hoMWAngYUKB1Y@xxxxxxxxxxxxxx> <20101001211111.GA18244@xxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
On Fri, Oct 1, 2010 at 2:11 PM, Konrad Rzeszutek Wilk
<konrad.wilk@xxxxxxxxxx> wrote:
> On Mon, Sep 27, 2010 at 08:52:39AM -0700, Bruce Edge wrote:
>> One of our developers who is working on a tachyon driver is
>> complaining that the pvops domU kernel is not working for these MSI
>> interrupts.
>> This is using the current head of xen/2.6.32.x on both a single
>> Nahelam 920 and a dual E5540. This behavior is consistent with Xen
>> 4.0.1, 4.0.2.rc1-pre and 4.1.
> I just checked on my SuperMicro X8DTN, this combination
>  - For Dom0, git commit fe999249 (
>  - For DomU, devel/xen-pcifront-0.6 or devel/xen-pcifront-0.7


Apologies in advance for the rookie git questions.

I'm assuming the git repos you mentioned are based on
git://git.kernel.org/pub/scm/linux/kernel/git/konrad/xen.git ?

Your devel/xen-pcifront-0.7 isn't visible:

%> git branch -r  | grep devel/xen-pcifront


and your devel/xen-pcifront-0.6 forces a config restart:

0 %> make oldconfig
scripts/kconfig/conf --oldconfig arch/x86/Kconfig
* Restart config...
* General setup
Prompt for development and/or incomplete code/drivers (EXPERIMENTAL) [Y/n/?] y
Cross-compiler tool prefix (CROSS_COMPILE) [] (NEW) ^Cmake[1]: ***
[oldconfig] Interrupt
make: *** [oldconfig] Interrupt

Is there a trick to avoiding the config restart?


>  - For Hypervisor I used cs 21976, but found that the latest (22155) works too
> with which where I passed in PCI devices with legacy IRQ, MSI, and MSI-X. I 
> tried
> a combination of doing this with IOMMU (VT-d) and without - both cases these 
> devices:
> 00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI 
> Controller #1 (rev 02)
> 00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI 
> Controller #2 (rev 02)
> 00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI 
> Controller #3 (rev 02)
> 00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI 
> Controller #1 (rev 02)
> 03:00.0 Ethernet controller: Intel Corporation 82572EI Gigabit Ethernet 
> Controller (Copper) (rev 06)
> 0a:00.1 Ethernet controller: Intel Corporation 82575EB Gigabit Network 
> Connection (rev 02)
> worked just fine (either defining pci=["..."] or just using pci-attach).
> But if I use the latest xen/next or xen/stable-2.6.32.x it does not look
> that happy :-(

Xen-devel mailing list