This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] pvops0 kernel does not boot

To: Andreas Kinzler <ml-xen-devel@xxxxxx>
Subject: Re: [Xen-devel] pvops0 kernel does not boot
From: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Date: Fri, 01 Oct 2010 09:50:48 -0700
Cc: jeremy.fitzhardinge@xxxxxxxxxx, xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 01 Oct 2010 09:52:02 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4CA5BDA9.60603@xxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <4C8E2AC5.8090602@xxxxxx> <4C8EA02F.5070402@xxxxxxxx> <4C90A2ED.2060805@xxxxxx> <4C9103A9.9050606@xxxxxxxx> <4C9112D1.902@xxxxxx> <4C912D31.5020209@xxxxxxxx> <4C91ECBD.6030105@xxxxxx> <4C9A2C16.80709@xxxxxx> <4C9A3B76.9030705@xxxxxxxx> <4CA5BDA9.60603@xxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100921 Fedora/3.1.4-1.fc13 Lightning/1.0b3pre Thunderbird/3.1.4
 On 10/01/2010 03:53 AM, Andreas Kinzler wrote:
> On 22.09.2010 19:23, Jeremy Fitzhardinge wrote:
>>>>>>>>>> current git stable 2.6.32.x (2968b25) crashes on boot with the
>>>>>>>>>> attached debug output. The same config file works perfectly on
>>>>>>>>>> (e6b9b2c).
>>>>>>>>> Thanks for the report. I've pushed an update to
>>>>>>>>> xen/stable-2.6.32.x
>>>>>>>>> which should fix this.
>>>>>>>> Sorry, still does not boot. I attached the serial console log and
>>>>>>>> manually created a traceback from the stack hex dump.
>>>>>>> Does adding "mem=1g" to the kernel command line help?
>>>>>> No (log attached). But the stacktrace changed back to the first
>>>>>> "version":
>>> Are you still checking this? Any news?
>> Haven't forgotten about it, but I was waiting for some inspiration to
>> strike.  Could you try some earlier versions and try to isolate when the
>> problem appeared?
> Actually I found something very strange. Even the vanilla kernels from
> kernel.org stopped working as a domU with the transition of
> to No output, no log, no nothing, just eating CPU time. Are
> there any debug options how to debug domUs that don't output anything?
> I am actually starting to wonder if the problems are related to
> kernels at all. I tried Xen 3.4.4 with the same result. Perhaps the
> whole problem is a binutils/gcc problem. What is your version of
> binutils / gcc / glibc?

Vanilla upstream and 23 are broken due to a typo that crept
into a Xen patch between mainline and stable-2.6.32; I'm still waiting
for that fix to hit (stable-2.6.35 was also affected, but it has since
been fixed).

Change b0dd220aefe1a is the fix, included below.

And on the subject of the original bug, I committed some fixes which may
fix it for you (certainly fixed *some* memory init stuff), so if you
could test out xen/next-2.6.32 I'd appreciate it.


From: James Dingwall <james.dingwall@xxxxxxxxxx>
Date: Mon, 27 Sep 2010 09:37:17 +0100
Subject: [PATCH] Xen: fix typo in previous patch

Correctly name the irq_chip structure to fix an immediate failure when booting
as a xen pv_ops guest with a NULL pointer exception. The missing 'x' was
introduced in commit [fb412a178502dc498430723b082a932f797e4763] applied to
2.6.3[25]-stable trees.  The commit to mainline was
[aaca49642b92c8a57d3ca5029a5a94019c7af69f] which did not have the problem.

Signed-off-by: James Dingwall <james@xxxxxxxxxxxxxx>
Reported-by: Pawel Zuzelski <pawelz@xxxxxxxxxxxxx>
Tested-by: Pawel Zuzelski <pawelz@xxxxxxxxxxxxx>
Signed-off-by: Greg Kroah-Hartman <gregkh@xxxxxxx>

diff --git a/drivers/xen/events.c b/drivers/xen/events.c
index 14ed358..6830a4d 100644
--- a/drivers/xen/events.c
+++ b/drivers/xen/events.c
@@ -935,7 +935,7 @@ static struct irq_chip xen_dynamic_chip __read_mostly = {
        .retrigger      = retrigger_dynirq,
-static struct irq_chip en_percpu_chip __read_mostly = {
+static struct irq_chip xen_percpu_chip __read_mostly = {
        .name           = "xen-percpu",
        .disable        = disable_dynirq,

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>