This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] pvops0 kernel does not boot

To: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Subject: Re: [Xen-devel] pvops0 kernel does not boot
From: Andreas Kinzler <ml-xen-devel@xxxxxx>
Date: Fri, 01 Oct 2010 12:53:29 +0200
Cc: jeremy.fitzhardinge@xxxxxxxxxx, xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 01 Oct 2010 03:56:39 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4C9A3B76.9030705@xxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <4C8E2AC5.8090602@xxxxxx> <4C8EA02F.5070402@xxxxxxxx> <4C90A2ED.2060805@xxxxxx> <4C9103A9.9050606@xxxxxxxx> <4C9112D1.902@xxxxxx> <4C912D31.5020209@xxxxxxxx> <4C91ECBD.6030105@xxxxxx> <4C9A2C16.80709@xxxxxx> <4C9A3B76.9030705@xxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20100915 Thunderbird/3.1.4
On 22.09.2010 19:23, Jeremy Fitzhardinge wrote:
current git stable 2.6.32.x (2968b25) crashes on boot with the
attached debug output. The same config file works perfectly on (e6b9b2c).
Thanks for the report. I've pushed an update to xen/stable-2.6.32.x
which should fix this.
Sorry, still does not boot. I attached the serial console log and
manually created a traceback from the stack hex dump.
Does adding "mem=1g" to the kernel command line help?
No (log attached). But the stacktrace changed back to the first
Are you still checking this? Any news?
Haven't forgotten about it, but I was waiting for some inspiration to
strike.  Could you try some earlier versions and try to isolate when the
problem appeared?

Actually I found something very strange. Even the vanilla kernels from kernel.org stopped working as a domU with the transition of to No output, no log, no nothing, just eating CPU time. Are there any debug options how to debug domUs that don't output anything?

I am actually starting to wonder if the problems are related to kernels at all. I tried Xen 3.4.4 with the same result. Perhaps the whole problem is a binutils/gcc problem. What is your version of binutils / gcc / glibc?

Regards Andreas

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>