This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] domU guest for xcp 0.1.1

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] domU guest for xcp 0.1.1
From: Ritu kaur <ritu.kaur.us@xxxxxxxxx>
Date: Sun, 11 Apr 2010 10:11:40 -0700
Delivery-date: Sun, 11 Apr 2010 10:12:47 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:received:message-id:subject:from:to:content-type; bh=aISik+eOw4jygPfPPi2rYPaddPvqSJcuZKLdfeBYmIg=; b=Rl53FmoubIUKMGdikfGeughbMTzqZUrl0HNQeZosieTXdrSyl+TlDq3rYu99Fo4Xg2 Ot3EjU3mBZ64RuP6j99TmxOW1a2xs1lEqeSkax/ib3/TQzGk61itFYsyZDUnzD1a9emC Ef+EMziVGHRnrs/2D/JxZK+EDzlHeY22BIhwo=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :content-type; b=GEMuNvGmQZgKyPbU96R7ZjOiZNbyit9pjvmWG2kmgKv5LAcmZxtARfNj4980nmDWEu 3aHmEzkgqmKIvbKUvxEfi/31q5m6QyrBU6zicvT7SMoMaYaNvGvRZjDk1/516ByedMIn /eUIIwSudtB6L06uLUE2+b3lWQOcvBo+BfxGo=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <h2x29b32d341004090853q7f2be5c9l2b42880dc40ffe21@xxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20100331063035.GI1878@xxxxxxxxxxx> <20100331143913.GL1878@xxxxxxxxxxx> <h2i29b32d341003311410j6ce550c5k325b9707c6e66cc0@xxxxxxxxxxxxxx> <v2x29b32d341004010548y80eb3c5bxe83b328001da9a85@xxxxxxxxxxxxxx> <j2z29b32d341004050710w997a9f8aka0b44c309e080620@xxxxxxxxxxxxxx> <20100405170013.GA16921@xxxxxxxxxxxxxxxxxxx> <g2p29b32d341004052100ja56a4fi7967fa4dcc65462e@xxxxxxxxxxxxxx> <20100406060337.GQ1878@xxxxxxxxxxx> <l2h29b32d341004060631v5e8447d6h98acea18b461f32@xxxxxxxxxxxxxx> <h2x29b32d341004090853q7f2be5c9l2b42880dc40ffe21@xxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx

Any inputs on backporting changes to xcp 2.6.27 source?

In addition, I had another question. I believe pci-passthrough works for pci-e slots as well. I have not tested it just wanted to check if any additional config changes are needed to make it work?


On Fri, Apr 9, 2010 at 8:53 AM, Ritu kaur <ritu.kaur.us@gmail.com> wrote:
Our technical guru/consultant suggested to check if backporting fixes(changes for shared interrupts) into 2.6.27 XCP source is feasible? i.e

XCP 2.6.27 source + fix(es) for shared interrupts = pci-passthrough work seamlessly

If it is possible do let me know and pointer to the changes would be helpful as well.


On Tue, Apr 6, 2010 at 6:31 AM, Ritu kaur <ritu.kaur.us@gmail.com> wrote:
Thanks Pasi. When will new xcp with 2.6.32 kernel be released?

Replies inline...

On Mon, Apr 5, 2010 at 11:03 PM, Pasi Kärkkäinen <pasik@xxxxxx> wrote:
On Mon, Apr 05, 2010 at 09:00:59PM -0700, Ritu kaur wrote:
>    Thanks Konrad.
>    I downloaded new code and still doesn't work(albeit different problem). I
>    will enumerate them below
>    (Please note 1, 2 and 3 are seen with old xen/next as well). What seemed
>    simple testing of pci passthrough via config changes doesn't seem to be
>    the case.
>    1. mkinitrd doesn't work in xcp ddk. I get below errors
>    mkinitrd -f ./initrd-2.6.32.ing 2.6.32
>    modinfo: could not find module ide-disk
>    No module ide-disk found for kernel 2.6.32, aborting.

Did you install the modules after you compiled the kernel?
Did you run "depmod -a <kernelversion>" ?

yes I have done it and still the same problem.
>    I copied ide-disk.ko from
>    /lib/modules/
>    to check what other errors arise from mkinitrd in xcp ddk), I get

You can't modules from a different kernel version!!!

I understand that. Just want to check what additional problems arise.
>    mkinitrd -f ./initrd-2.6.32.ing 2.6.32
>    modinfo: could not find module ide-disk
>    modinfo: could not find module dm-mem-cache
>    modinfo: could not find module dm-message
>    modinfo: could not find module dm-raid45

Looks like you didn't install the modules from the new kernel.

I have installed modules via "make modules_install" and depmod as well.

>    2. Looked into .config I have(generated via make menuconfig) and there
>    isn't anything on IDEDISK. I cross checked config file that comes with xcp
>    source code it has
>    ...
>    ...

XCP default kernel is 2.6.27. You're trying to use 2.6.32.
There might have been changes between the kernel versions.

>    I copied above configs into my .config and when I run make(it asks some
>    IDE config related questions ) and these configs are deleted after that. I
>    have tried all options "y/n/m" to the questions and same result.
>    3. I downloaded .config file from
>    [1]http://pasik.reaktio.net/xen/pv_ops-dom0-debug/config-
>    there isn't IDEDISK config in it either and in addition "make tar-pkg"
>    doesn't work with this .config file. I get following errors

If ide-disk module is not used/required anymore in 2.6.32, then you should
remove it from /etc/modprobe.conf so that mkinitrd doesn't try to include it!

(replace it with the proper new module name).

>    DEPMOD  2.6.32
>    /bin/sh: line 1:  3341 Killed                  /sbin/depmod -ae -F
>    System.map -b /root/kernel/linux-2.6.32/tar-install 2.6.32
>    make[3]: *** [_modinst_post] Error 137
>    make[2]: *** [sub-make] Error 2
>    make[1]: *** [tar-pkg] Error 2
>    make: *** [tar-pkg] Error 2
>    4. I tried with the vmlinuz and initrd image built from "2" above(I know
>    initrd image is not correct, I just wanted to try) and I get
>    [0.000000] ERROR: Unable to locate IOAPIC for GSI 2
>    [0.000000] ERROR: Unable to locate IOAPIC for GSI 9
>    [0.000000] ERROR: Unable to locate IOAPIC for GSI 2
>    [0.000000] ERROR: Unable to locate IOAPIC for GSI 9
>    [0.493572] registering netback
>    Red Hat nash version starting
>    einsmod: error inserting 'lib/ide-disk.ko': -1 Invalid module format

"Invalid module format" means it's from a different kernel and cannot be
used with this kernel.

>    indmos: error inserting '/lib/dm-region-hash.ko': -1 File Exists
>    mount: could not fine filesystem '/dev/root'
>    setuproot: moving /dev failed: No such file or directory
>    setuproot: error mounting /proc: No such file or directory
>    setuproot: error mounting /sys: No such file or directory
>    switchroot: mount failed: No such file or directory
>    [0.905987] Kernel panic - not syncing: Attempted to kill init!
>    Let me know how to proceed on this.

Install for example Fedora 12, or any other distro that has 2.6.32 kernel
as a default, and check which modules are used for your hardware,
then replace "ide-disk" in modprobe.conf with the actual module.

Will look into it.


-- Pasi

>    Thanks
>    On Mon, Apr 5, 2010 at 10:00 AM, Konrad Rzeszutek Wilk
>    <[2]konrad.wilk@xxxxxxxxxx> wrote:
>      On Mon, Apr 05, 2010 at 07:10:22AM -0700, Ritu kaur wrote:
>      > Hello,
>      >
>      > Any inputs folks on xen debugs provided? dom0 crashes when  xen/next
>      kernel
>      What you are hitting should have been fixed a week ago. Are you up to
>      the latest in xen/next? Did you do 'git pull' ? Do you see this as the
>      latest when you do 'git log | head':
>       git log | head -5
>      commit 900f6d725874ca97c21cdc5a2c4e05bd62db4e86
>      Merge: f2530fa 89689b1
>      Author: Jeremy Fitzhardinge <[3]jeremy.fitzhardinge@xxxxxxxxxx>
>      Date:   Thu Apr 1 14:24:30 2010 -0700
> References
>    Visible links
>    1. http://pasik.reaktio.net/xen/pv_ops-dom0-debug/config-
>    2. mailto:konrad.wilk@xxxxxxxxxx
>    3. mailto:jeremy.fitzhardinge@xxxxxxxxxx

> _______________________________________________
> Xen-devel mailing list

Xen-devel mailing list