This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] domU guest for xcp 0.1.1

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] domU guest for xcp 0.1.1
From: Ritu kaur <ritu.kaur.us@xxxxxxxxx>
Date: Mon, 5 Apr 2010 21:00:59 -0700
Delivery-date: Mon, 05 Apr 2010 21:01:47 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:received:message-id:subject:from:to:content-type; bh=2dVuMaTBeqSFa9w+I87EBExCvhEplVFUMGiI+hhE0Kg=; b=A96rqSPWfhC2blwaMJkcv9MjekauK2QUxaZIWakjgHI51AD/fhLIvUFnP7z2A/x/y6 6LKGDaqupWX3X09sikeq3jBpv0trL0DOv3iArLoTJX1ay1xqp1sBbJZEjwUavP6eF27S ss4IHsWGdU5RikQPEBKF6IikPVBBngjVm86dM=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :content-type; b=D+HIzSmfTD5Z4ya5aJJbd9ezNQAemWMo1Y+IhjDY0ndQ3btkT2A+j9HQb8jqmBNJvN 0HA9i31n4zOjsBneOd4VomdSBziDoM8F9qDcOEkLW/5D6yaaupWcOIBHvdprnkR0aTky oBpHo2zydkiSY75aTBOv1wAGOdMiT8+uWps3M=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20100405170013.GA16921@xxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <h2q29b32d341003301728q8b505cebx1c0326d9451121f5@xxxxxxxxxxxxxx> <20100331063035.GI1878@xxxxxxxxxxx> <z2r29b32d341003310615wd6a0a690nac365f3011aaf5cf@xxxxxxxxxxxxxx> <20100331134210.GD28074@xxxxxxxxxxxxxxxxxxx> <k2w29b32d341003310655ha47eb0e4y88f85e34f3aec964@xxxxxxxxxxxxxx> <20100331143913.GL1878@xxxxxxxxxxx> <h2i29b32d341003311410j6ce550c5k325b9707c6e66cc0@xxxxxxxxxxxxxx> <v2x29b32d341004010548y80eb3c5bxe83b328001da9a85@xxxxxxxxxxxxxx> <j2z29b32d341004050710w997a9f8aka0b44c309e080620@xxxxxxxxxxxxxx> <20100405170013.GA16921@xxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Thanks Konrad.

I downloaded new code and still doesn't work(albeit different problem). I will enumerate them below

(Please note 1, 2 and 3 are seen with old xen/next as well). What seemed simple testing of pci passthrough via config changes doesn't seem to be the case.

1. mkinitrd doesn't work in xcp ddk. I get below errors

mkinitrd -f ./initrd-2.6.32.ing 2.6.32
modinfo: could not find module ide-disk
No module ide-disk found for kernel 2.6.32, aborting.

I copied ide-disk.ko from /lib/modules/ to check what other errors arise from mkinitrd in xcp ddk), I get

mkinitrd -f ./initrd-2.6.32.ing 2.6.32
modinfo: could not find module ide-disk
modinfo: could not find module dm-mem-cache
modinfo: could not find module dm-message
modinfo: could not find module dm-raid45

2. Looked into .config I have(generated via make menuconfig) and there isn't anything on IDEDISK. I cross checked config file that comes with xcp source code it has

I copied above configs into my .config and when I run make(it asks some IDE config related questions ) and these configs are deleted after that. I have tried all options "y/n/m" to the questions and same result.

3. I downloaded .config file from http://pasik.reaktio.net/xen/pv_ops-dom0-debug/config-

there isn't IDEDISK config in it either and in addition "make tar-pkg" doesn't work with this .config file. I get following errors

DEPMOD  2.6.32

/bin/sh: line 1:  3341 Killed                  /sbin/depmod -ae -F System.map -b /root/kernel/linux-2.6.32/tar-install 2.6.32
make[3]: *** [_modinst_post] Error 137
make[2]: *** [sub-make] Error 2
make[1]: *** [tar-pkg] Error 2
make: *** [tar-pkg] Error 2

4. I tried with the vmlinuz and initrd image built from "2" above(I know initrd image is not correct, I just wanted to try) and I get

[0.000000] ERROR: Unable to locate IOAPIC for GSI 2
[0.000000] ERROR: Unable to locate IOAPIC for GSI 9
[0.000000] ERROR: Unable to locate IOAPIC for GSI 2
[0.000000] ERROR: Unable to locate IOAPIC for GSI 9
[0.493572] registering netback
Red Hat nash version starting
einsmod: error inserting 'lib/ide-disk.ko': -1 Invalid module format
indmos: error inserting '/lib/dm-region-hash.ko': -1 File Exists
mount: could not fine filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
[0.905987] Kernel panic - not syncing: Attempted to kill init!

Let me know how to proceed on this.


On Mon, Apr 5, 2010 at 10:00 AM, Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx> wrote:
On Mon, Apr 05, 2010 at 07:10:22AM -0700, Ritu kaur wrote:
> Hello,
> Any inputs folks on xen debugs provided? dom0 crashes when  xen/next kernel

What you are hitting should have been fixed a week ago. Are you up to
the latest in xen/next? Did you do 'git pull' ? Do you see this as the
latest when you do 'git log | head':

 git log | head -5
commit 900f6d725874ca97c21cdc5a2c4e05bd62db4e86
Merge: f2530fa 89689b1
Author: Jeremy Fitzhardinge <jeremy.fitzhardinge@xxxxxxxxxx>
Date:   Thu Apr 1 14:24:30 2010 -0700

Xen-devel mailing list