This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Xen killing my e1000s?

To: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Subject: Re: [Xen-devel] Xen killing my e1000s?
From: Andrew Lyon <andrew.lyon@xxxxxxxxx>
Date: Sat, 12 Dec 2009 14:16:11 +0000
Cc: Xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Sat, 12 Dec 2009 06:16:33 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:cc:content-type :content-transfer-encoding; bh=oUMQ5dZ94e5oCEUWnt8M1DSRFMLwRPRMTXMxTR9rObc=; b=seYQC9+PZdIyb3W4i3w0WQuqGAGZdsYfGdzYcRF9wz5jYlndJ4Yk/d+FGiCd9sxc6A 9XyCIBdwV0RXQFZ86IVHC+nOQUPbUzCIje+uM/xOyVk78yzss0hJIalZ7wT9dLBWi8/b eUrepSLhKAawMVGBaZJJ2NKWmQTqEIiNAu5yw=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=HcNR2iXHCtIf2msje1Tqddw/2FkfB2Z45+izj+ErCyHEAjGdDE87k0PW0o/0p3+N4x 9DR2HdMDJatq9GySuoCIAPbWf9DV85o7T8LXf5VMHgkENtkFeZ871UND1Y6rl24vaagm mUovRkm0m2ew3Z29DKNd4rHghYo9pF8geLkyo=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4B22D781.5090704@xxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <4B22D781.5090704@xxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
On Fri, Dec 11, 2009 at 11:36 PM, Jeremy Fitzhardinge <jeremy@xxxxxxxx> wrote:
> I have this Xeon 3430-based system with a pair of on-board PCI-e e1000s.
>  When I'm running under Xen, they disappear in use.  That is, the PCI
> devices themselves seem to give up the ghost, and lspci -x shows all 0xff
> for their config spaces. They come back to life when I reset the machine.
> When I boot under native Linux all seems fine.
> I'm running with VT-d and all the other features enabled; I haven't tried
> turning them off yet.  There are no obvious messages from the kernel or Xen
> complaining about anything.
> This is a new machine, so it could be an outright hardware problem, but it
> seems like an odd failure-mode for a hardware fault (I'd expect on-board
> devices to either work or not work, and not come back on reset).
> Anyone got any ideas?
> Thanks,
>    J
> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-devel

Have you tried using the latest version of the e1000 driver from intel
rather than the in-kernel one? I've had the same problem when using
older kernels on systems with e1000 and Xen, I used the intel driver
for a while but once I switched to using a newer dom0 kernel the
problem went away.


Xen-devel mailing list