This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Problem with 2.6.30 pv-ops domU

To: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Subject: Re: [Xen-devel] Problem with 2.6.30 pv-ops domU
From: Jia Rao <rickenrao@xxxxxxxxx>
Date: Tue, 1 Dec 2009 00:10:00 -0500
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Mon, 30 Nov 2009 21:10:29 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:cc:content-type; bh=aOeHcfxrBZ43fh+KcmZyRnuJPaUNKiMn92unPvvjQ9g=; b=QfyC8xXuhkBmpRlhRVGlLq4lS4Aq6J20r2aytCo9TKcVpGeELRpvCYR6/NcEsCILUq 25VLbCQ8y5R+Zb10foekTc53IMXkt/VK+xZAmUOZux6sAJL/gaAC2pjX1FBcjARZhDPm j2BxJL+W0ccfvLpduSAMggkhXh2intSx2B5yo=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type; b=MRf8sEFamdqk/FEXWPbJ3ANBnQNPRmgPuMisUCxatgUjoyX+nIBlgYhODf/nvFmla6 i4+0152YZ7qHszabKhQeOONgmP4Z96qqKpp460xUOwAj+TKngSoysX60WqRp0UgPy+4E EBkHbjXP8k7BuLOwcOyfMb0ZM7kBQsYv1VhyY=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4B146260.7070205@xxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <994429490911292136o39c37116m7761de6f647b363d@xxxxxxxxxxxxxx> <4B143431.2040804@xxxxxxxx> <994429490911301344s761d245bs2fd2f4f8bf57aa24@xxxxxxxxxxxxxx> <4B146260.7070205@xxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
The problem was solved. It turned out to be the blktap support in pv_ops.
I configured all the VM disks as tap:aio which seems to be waiting for tap:aio 2.
After changed to file based disk, everything is fine up to now.

On Mon, Nov 30, 2009 at 7:25 PM, Jeremy Fitzhardinge <jeremy@xxxxxxxx> wrote:
On 11/30/09 13:44, Jia Rao wrote:
> OK, the shrinking is working now. What I do now is to set a large
> initial memory size.
> Another problem is with the newest pv_ops kernel.
> I downloaded the xen-unstable, and compiled it under fedora 10.
> Dom0 booted fine, but when I cp the dom0 to a domU (what I did in the
> stable xen release, convert physical to virtual), the domU can boot,
> but immediately the vcpu(i set to 2) shrinked to 1 vcpu and the cpu
> was 100% busy there.

What do you mean by "shrinked to 1"?

> ping and xm console returned nothing.
> The same thing happened when I install a precompiled pv_ops kernel to
> my old domUs.
> I tried xen 3.3.1 ( dom0) and xen-unstable( dom0),
> same problem.
> So I think the problem should be the pv_ops kernel.

What happens if you run with one vcpu?
What messages are printed when it boots?  Any?  Do you have
"earlyprintk=xen" on the kernel command line?
Does it respond to sysrq?
Can you get any info about the domain with xenctx?

> Do I need some special configuration for pv_ops kernel to use as a domU?



Xen-devel mailing list