This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Problem with 2.6.30 pv-ops domU

To: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Subject: Re: [Xen-devel] Problem with 2.6.30 pv-ops domU
From: Jia Rao <rickenrao@xxxxxxxxx>
Date: Mon, 30 Nov 2009 16:44:19 -0500
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Mon, 30 Nov 2009 13:44:44 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:cc:content-type; bh=XdU1rE2ICFXEc/LGCYyUUuZXpYAhocHc9fvAFG4r80I=; b=veRsVtx+W53ofSCfVz3OKQFP9sqXz35zNC/SUJpD3O2eWU54nKJgsd33BYSMMhVmRL tw7LbUAAAizUgbYJRlx5udX1Hp7mwmjHcL2XXEsXz6WbEZFeI/iWlnE57uUGeF8kGrCR A+F5+kALTsZ/hnmMh+pvQdmpc93C53tGnL/Dw=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type; b=ulPcNMn0WFJqpbDaRM8k0u92cgfLeZWWY1YYbYfdIQOARgTsqPtuz/XzDZIhTBf3K/ B4ksnvNkUUKJJF/dyhYDDSEwAKJfIpe8b+8oYywZ0zO1o9aRikM32C8Pt7ae6R7ixvK3 n6fJGlvCA4f8EopxFfApsbCxZG8jd3yTCEuQI=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4B143431.2040804@xxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <994429490911292136o39c37116m7761de6f647b363d@xxxxxxxxxxxxxx> <4B143431.2040804@xxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
OK, the shrinking is working now. What I do now is to set a large initial memory size.

Another problem is with the newest pv_ops kernel.

I downloaded the xen-unstable, and compiled it under fedora 10.

Dom0 booted fine, but when I cp the dom0 to a domU (what I did in the stable xen release, convert physical to virtual), the domU can boot, but immediately the vcpu(i set to 2) shrinked to 1 vcpu and the cpu was 100% busy there.

ping and xm console returned nothing.

The same thing happened when I install a precompiled pv_ops kernel to my old domUs.
I tried xen 3.3.1 ( dom0) and xen-unstable( dom0), same problem.
So I think the problem should be the pv_ops kernel.

Do I need some special configuration for pv_ops kernel to use as a domU?

Thanks !
On Mon, Nov 30, 2009 at 4:08 PM, Jeremy Fitzhardinge <jeremy@xxxxxxxx> wrote:
On 11/29/09 21:36, Jia Rao wrote:
> Hi all,
> I downloaded a pre-compiled Fedora 11 domU image from
> http://stacklet.com/downloads/images/list/Fedora
> When I ran the domU (2.6.30) with xen 3.3.1, 2.6.18 dom0, there was a
> problem.
> I can not change the memory configuration of the domU on the fly. I
> used pygrub to boot the PV guest.
> In the 2.6.30 guest, I can not find the /proc/xen/balloon driver but
> in the config file of the kernel, XEN_BALLOON is enabled.

How were you trying to change the memory?  At present, it only supports
shrinking memory, not expanding it beyond its original size.


Xen-devel mailing list